public inbox for [email protected]
help / color / mirror / Atom feedFrom: Andrei Lepikhov <[email protected]>
To: Richard Guo <[email protected]>
To: PostgreSQL-development <[email protected]>
Subject: Re: Some dead code in get_param_path_clause_serials()
Date: Wed, 13 Nov 2024 19:59:04 +0700
Message-ID: <[email protected]> (raw)
In-Reply-To: <CAMbWs4_Puie4DQ2ODvjQB_3CxYkUODnrJm8jn_ObMAcrjYNW7Q@mail.gmail.com>
References: <CAMbWs4_Puie4DQ2ODvjQB_3CxYkUODnrJm8jn_ObMAcrjYNW7Q@mail.gmail.com>
On 11/13/24 16:34, Richard Guo wrote:
> The function get_param_path_clause_serials() is used to get the set of
> pushed-down clauses enforced within a parameterized Path. Since we
> don't currently support parameterized MergeAppend paths, and it
> doesn't look like that is going to change anytime soon (as explained
> in the comments for generate_orderedappend_paths), we don't need to
> consider MergeAppendPath in this function. Is it worth removing the
> related code, as attached?
>
> This change won't make any measurable difference in performance; it's
> just for clarity's sake.
I've passed through the logic of
get_param_path_clause_serials/reparameterize_path_by_child/reparameterize_path.
Agree, it seems not useful to parameterise ordered appends in the near
future. Even So, it would be better to insert changes, induced by new
feature by one commit.
By the way, Do you know if anyone gave a speech on the current state of
internal plan parameterisation and its possible development directions?
It would be helpful to have such an explanation.
--
regards, Andrei Lepikhov
view thread (6+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected]
Subject: Re: Some dead code in get_param_path_clause_serials()
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox