pg.ddx.io pgsql-hackers@postgresql.org mailing list archive
help / color / mirror / Atom feedpg_namespace -> pg_schema?
4+ messages / 4 participants
[nested] [flat]
* pg_namespace -> pg_schema?
@ 2003-04-25 21:39 Sean Chittenden <sean@chittenden.org>
0 siblings, 1 reply; 4+ messages in thread
From: Sean Chittenden @ 2003-04-25 21:39 UTC (permalink / raw)
To: pgsql-hackers
I know pg_namespace has been in release for one rev, but I was
wondering if for consistency sake there was any interest or desire or
plans to change the system catalog to pg_schema.
CREATE SCHEMA [schema_name];
SET search_path = foo,pubic;
SELECT * FROM pg_namespace;
SELECT * FROM information_schema.schemata;
The four naming schemes seem a bit disjointed. I know schemata is
spec mandated, but the others aren't frozen by anything as far as I
can tell. If 7.3.3 is going to be around for a while, it might be
nice to setup transitional warning and 1:1 views that allow:
CREATE SCHEMA [schema_name];
SET schema_path = foo,public;
SELECT * FROM pg_schema;
to work. Just some thoughts after trying to explain the different
naming practices to someone and being unable to give a good
justification for namespaceo != schema != search_path. Given the
feature hasn't been around that long (only 8mo), figured it might be
worth considering now vs. in 5 years when it becomes apparent that
there not semantically connected even though they all revolve around
the same concept of schemas. -sc
--
Sean Chittenden
^ permalink raw reply [nested|flat] 4+ messages in thread
* Re: pg_namespace -> pg_schema?
@ 2003-04-25 22:20 Tom Lane <tgl@sss.pgh.pa.us>
parent: Sean Chittenden <sean@chittenden.org>
0 siblings, 1 reply; 4+ messages in thread
From: Tom Lane @ 2003-04-25 22:20 UTC (permalink / raw)
To: Sean Chittenden <sean@chittenden.org>; +Cc: pgsql-hackers
Sean Chittenden <sean@chittenden.org> writes:
> I know pg_namespace has been in release for one rev, but I was
> wondering if for consistency sake there was any interest or desire or
> plans to change the system catalog to pg_schema.
No. The choice of catalog name was deliberate: a namespace is not
necessarily identical to a schema. In any case, I can see no value
to renaming it at this late date.
regards, tom lane
^ permalink raw reply [nested|flat] 4+ messages in thread
* Re: [HACKERS] pg_namespace -> pg_schema?
@ 2003-04-29 22:19 Andreas Pflug <Andreas.Pflug@web.de>
parent: Tom Lane <tgl@sss.pgh.pa.us>
0 siblings, 1 reply; 4+ messages in thread
From: Andreas Pflug @ 2003-04-29 22:19 UTC (permalink / raw)
To: Tom Lane <tgl@sss.pgh.pa.us>; Dave Page <dpage@vale-housing.co.uk>; pgadmin-hackers@postgresql.org
Tom Lane wrote:
>Sean Chittenden <sean@chittenden.org> writes:
>
>
>>I know pg_namespace has been in release for one rev, but I was
>>wondering if for consistency sake there was any interest or desire or
>>plans to change the system catalog to pg_schema.
>>
>>
>
>No. The choice of catalog name was deliberate: a namespace is not
>necessarily identical to a schema. In any case, I can see no value
>to renaming it at this late date.
>
> regards, tom lane
>
>
I wonder if we should use the term NAMESPACE instead of SCHEMA in pgAdmin3.
Any suggestions?
Andreas
^ permalink raw reply [nested|flat] 4+ messages in thread
* Re: [HACKERS] pg_namespace -> pg_schema?
@ 2003-04-30 08:11 Dave Page <dpage@vale-housing.co.uk>
parent: Andreas Pflug <Andreas.Pflug@web.de>
0 siblings, 0 replies; 4+ messages in thread
From: Dave Page @ 2003-04-30 08:11 UTC (permalink / raw)
To: Andreas.Pflug@web.de; +Cc: tgl@sss.pgh.pa.us; dpage@vale-housing.co.uk; pgadmin-hackers@postgresql.org
It's rumoured that Andreas Pflug once said:
>>No. The choice of catalog name was deliberate: a namespace is not
>>necessarily identical to a schema. In any case, I can see no value to
>>renaming it at this late date.
>
> I wonder if we should use the term NAMESPACE instead of SCHEMA in
> pgAdmin3. Any suggestions?
In pgAdmin II I deliberately folowed Tom's lead and called them Namespaces
internally and Schemas externally to avoid any confusion on the issue.
Oh, and of course the main class library was already called pgSchema...
Regards, Dave.
^ permalink raw reply [nested|flat] 4+ messages in thread
end of thread, other threads:[~2003-04-30 08:11 UTC | newest]
Thread overview: 4+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2003-04-25 21:39 pg_namespace -> pg_schema? Sean Chittenden <sean@chittenden.org>
2003-04-25 22:20 ` Tom Lane <tgl@sss.pgh.pa.us>
2003-04-29 22:19 ` Andreas Pflug <Andreas.Pflug@web.de>
2003-04-30 08:11 ` Dave Page <dpage@vale-housing.co.uk>
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox