agora inbox for [email protected]  
help / color / mirror / Atom feed
From: Shigeru HANADA <[email protected]>
To: Kohei KaiGai <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: PostgreSQL-development <[email protected]>
Subject: Re: pgsql_fdw in contrib
Date: Fri, 13 Jul 2012 10:18:08 +0900
Message-ID: <[email protected]> (raw)
In-Reply-To: <CADyhKSXPP4-PNhK1VZa6zpvzxJuyqJJuzyJt6Yep_u3L2ttLNg@mail.gmail.com>
References: <[email protected]>
	<[email protected]>
	<[email protected]>
	<CADyhKSXPP4-PNhK1VZa6zpvzxJuyqJJuzyJt6Yep_u3L2ttLNg@mail.gmail.com>

(2012/07/12 20:48), Kohei KaiGai wrote:
> It seems to me what postgresql_fdw_validator() is doing looks like
> a function to be named as "libpq_fdw_validator()".
> 
> How about your opinion? It will help this namespace conflicts.

I'd prefer dblink_fdw_validator.

The name "libpq_fdw_validator" impresses me that a concrete FDW named
"libpq_fdw" is somewhere and it retrieves external data *from* libpq.
Indeed postgresql_fdw_validator allows only some of libpq options at the
moment, but we won't be able to rename it for backward compatibility
even if it wants to have non-libpq options in the future.

IMO basically each FDW validator should be owned by a particular FDW,
because in most cases validator should know FDW's internal deeply.  In
addition, it would want to have new options for new features.

Besides naming, as mentioned upthread, removing hard-coded libpq options
list from dblink and leaving it to libpq client library would make
dblink more robust about libpq option changes in future.

Regards,
-- 
Shigeru HANADA





view thread (27+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected], [email protected]
  Subject: Re: pgsql_fdw in contrib
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox