From: David Steele <david@pgmasters.net>
To: Abhijit Menon-Sen <ams@2ndQuadrant.com>
Cc: Stephen Frost <sfrost@snowman.net>
Cc: Álvaro Herrera <alvherre@2ndquadrant.com>
Cc: Fujii Masao <masao.fujii@gmail.com>
Cc: PostgreSQL-development <pgsql-hackers@postgresql.org>
Subject: Re: Auditing extension for PostgreSQL (Take 2)
Date: Wed, 01 Apr 2015 14:00:55 -0400
Message-ID: <551C3257.4000305@pgmasters.net> (raw)
In-Reply-To: <55104204.80008@pgmasters.net>
References: <54E005CC.1060605@pgmasters.net>
<20150217153402.GQ6717@tamriel.snowman.net>
<54EB4E56.7050102@pgmasters.net>
<54ECA551.8060306@pgmasters.net>
<20150323053146.GA1919@toroid.org>
<55104204.80008@pgmasters.net>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-hackers>
On 3/23/15 12:40 PM, David Steele wrote:
> On 3/23/15 1:31 AM, Abhijit Menon-Sen wrote:
>> I'm experimenting with a few approaches to do this without reintroducing
>> switch statements to test every command. That will require core changes,
>> but I think we can find an acceptable arrangement. I'll post a proof of
>> concept in a few days.
Any progress on the POC? I'm interested in trying to get the ROLE class
back in before the Commitfest winds up, but not very happy with my
current string-matching options.
>>> + * Takes an AuditEvent and, if it log_check(), writes it to the audit
>>> log.
>>
>> I don't think log_check is the most useful name, because this sentence
>> doesn't tell me what the function may do. Similarly, I would prefer to
>> have log_acl_check be renamed acl_grants_audit or similar. (These are
>> all static functions anyway, I don't think a log_ prefix is needed.)
>
> log_check() has become somewhat vestigial at this point since it is only
> called from one place - I've been considering removing it and merging
> into log_audit_event(). For the moment I've improved the comments.
log_check() got rolled into log_audit_event().
> I like acl_grants_audit() and agree that it's a clearer name. I'll
> incorporate that into the next version and apply the same scheme to the
> other ACL functionsas well as do a general review of naming.
I ended up going with audit_on_acl, audit_on_relation, etc. and reworked
some of the other function names.
I attached the v6 patch to my previous email, or you can find it on the
CF page.
--
- David Steele
david@pgmasters.net
Attachments:
signature.asc (application/pgp-signature, 818B) download
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: david@pgmasters.net, ams@2ndQuadrant.com, sfrost@snowman.net, alvherre@2ndquadrant.com, masao.fujii@gmail.com
Subject: Re: Auditing extension for PostgreSQL (Take 2)
In-Reply-To: <551C3257.4000305@pgmasters.net>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox