pg.ddx.io pgsql-hackers@postgresql.org mailing list archive
help / color / mirror / Atom feed From: Alexander Lakhin <exclusion@gmail.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
To: Justin Pryzby <pryzby@telsasoft.com>
Cc: Fabien COELHO <coelho@cri.ensmp.fr>
Cc: pgsql-hackers@postgresql.org, Alvaro Herrera <alvherre@2ndquadrant.com>
Cc: David Steele <david@pgmasters.net>
Cc: Bossart, Nathan <bossartn@amazon.com>
Cc: Thomas Munro <thomas.munro@gmail.com>
Subject: Re: pg11+: pg_ls_*dir LIMIT 1: temporary files .. not closed at end-of-transaction
Date: Fri, 13 Nov 2020 23:00:00 +0300
Message-ID: <83048c77-2531-48cb-aa2b-aa01cc5af519@gmail.com> (raw )
In-Reply-To: <11882.1585672910@sss.pgh.pa.us >
References: <24244.1585415634@sss.pgh.pa.us >
<20200328183904.GI20103@telsasoft.com >
<28906.1585422475@sss.pgh.pa.us >
<27064.1585499825@sss.pgh.pa.us >
<20200329171415.GL20103@telsasoft.com >
<29512.1585502524@sss.pgh.pa.us >
<20200329201215.GM20103@telsasoft.com >
<alpine.DEB.2.21.2003300704430.16227@pseudo >
<4028.1585579463@sss.pgh.pa.us >
<alpine.DEB.2.21.2003310723560.16227@pseudo >
<20200331080643.GE14618@telsasoft.com >
<11882.1585672910@sss.pgh.pa.us >
Hello hackers,
31.03.2020 19:41, Tom Lane wrote:
> Justin Pryzby <pryzby@telsasoft.com> writes:
>> I suggest to leave stat() alone in your patch for stable releases. I think
>> it's okay if we change behavior so that a broken symlink is skipped instead of
>> erroring (as a side effect of skipping ENOENT with stat()). But not okay if we
>> change pg_ls_logdir() to hide symlinks in back braches.
> Meh. I'm not really convinced, but in the absence of anyone expressing
> support for my position, I'll do it that way. I don't think it's worth
> doing both a stat and lstat to tell the difference between file-is-gone
> and file-is-a-broken-symlink.
As we've discovered in Bug #[16161], stat() for "concurrently-deleted
file" can also return ERROR_ACCESS_DENIED on Windows. It seems that
pg_upgradeCheck failures seen on
https://buildfarm.postgresql.org/cgi-bin/show_history.pl?nm=fairywren&br=REL_13_STABLE
caused by the same issue.
Shouldn't pg_ls_dir_files() retry stat() on ERROR_ACCESS_DENIED just
like the pgwin32_open() does to ignore files in "delete pending" state?
[16161]
https://www.postgresql.org/message-id/16161-7a985d2f1bbe8f71%40postgresql.org
Best regards,
Alexander
view thread (30+ messages) latest in thread
Message-ID: <83048c77-2531-48cb-aa2b-aa01cc5af519@gmail.com>
Permalink: ../83048c77-2531-48cb-aa2b-aa01cc5af519@gmail.com/
Also on: postgresql.org/message-id/83048c77-2531-48cb-aa2b-aa01cc5af519@gmail.com
copy link · copy postgr.es
reply Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: exclusion@gmail.com, tgl@sss.pgh.pa.us, pryzby@telsasoft.com, coelho@cri.ensmp.fr, alvherre@2ndquadrant.com, david@pgmasters.net, bossartn@amazon.com, thomas.munro@gmail.com
Subject: Re: pg11+: pg_ls_*dir LIMIT 1: temporary files .. not closed at end-of-transaction
In-Reply-To: <83048c77-2531-48cb-aa2b-aa01cc5af519@gmail.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox