public inbox for [email protected]
help / color / mirror / Atom feedFrom: Andreas Karlsson <[email protected]>
To: Heikki Linnakangas <[email protected]>
To: [email protected] <[email protected]>
Subject: Re: Little cleanup of ShmemInit function names
Date: Wed, 28 Aug 2024 17:26:38 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
On 8/7/24 2:08 PM, Heikki Linnakangas wrote:
> The attached patches rename them to follow the usual naming convention.
> The InitLocks() function is refactored a bit more, splitting the
> per-backend initialization to a separate InitLockManagerAccess()
> function. That's why it's in a separate commit.
I like the idea behind the patches. And they still apply and build.
The first patch is clean and well commented. I just have two minor nitpicks.
Small typo with the extra "which" which makes the sentence not flow
correctly
"This is called from CreateSharedMemoryAndSemaphores(), which see for
more comments."
On the topic of minor language issues I think the comma below is redundant.
"In the normal postmaster case, the shared hash tables are created here."
The second patch is a simple renaming which reduces mental load by
making the naming more consistent so I like it. Also since these
functions are not really useful for any extension authors I do not see
any harm in renaming them.
After cleaning up the language of that comment I think these patches can
be committed.
Andreas
view thread (2+ messages)
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected]
Subject: Re: Little cleanup of ShmemInit function names
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox