pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Sergei Kornilov <sk@zsrv.org>
To: Robert Haas <robertmhaas@gmail.com>
To: Dilip Kumar <dilipbalaut@gmail.com>
Cc: Jeevan Ladhe <jeevan.ladhe@enterprisedb.com>
Cc: Mark Dilger <mark.dilger@enterprisedb.com>
Cc: pgsql-hackers@postgresql.org <pgsql-hackers@postgresql.org>
Cc: tushar <tushar.ahuja@enterprisedb.com>
Subject: Re: refactoring basebackup.c
Date: Tue, 14 Sep 2021 18:30:22 +0300
Message-ID: <979131631633278@mail.yandex.ru> (raw)
In-Reply-To: <CA+Tgmoaqn1ZD_7eFVANOGVXxhdPCKc6g7OjBmQxiDkffBO_vhw@mail.gmail.com>
References: <CA+TgmoZGwR=ZVWFeecncubEyPdwghnvfkkdBe9BLccLSiqdf9Q@mail.gmail.com>
	<CA+TgmoZBqs7KkyBUFzXQaztuonKanuOV+f_7DYsHOpJs=0B2DA@mail.gmail.com>
	<CA+TgmoY5zpS=gJj2O0PXi6YGao5YR89v0qN_xZzWNvff2Tug+Q@mail.gmail.com>
	<58D2BD01-B541-4032-9C0B-B6143841E7ED@enterprisedb.com>
	<CA+TgmoYgVN=-Yoh71r3P9N7eKysd7_9b9s+1QFfFcs3w7Z-tig@mail.gmail.com>
	<CAOgcT0NqC3wNZ=sZWZ252xk6Q=BU_aeEMHE7FeiaP473FzTkgg@mail.gmail.com>
	<CA+TgmoaDEBWWxvyL0RZq8kJ9qu1fpJjqn=e7YK3SUB5UBnmTVQ@mail.gmail.com>
	<CA+TgmobvHoqeMc2+h8GRnvf2oLxpZkq1F8rS6fa47uk92QAxhw@mail.gmail.com>
	<CAFiTN-u8FGWedkSoyTOCZ96ZBWL8EJ-SfO4MYdQ_p6uY8Fc02A@mail.gmail.com>
	<CA+Tgmoaqn1ZD_7eFVANOGVXxhdPCKc6g7OjBmQxiDkffBO_vhw@mail.gmail.com>

Hello

I found that in 0001 you propose to rename few options. Probably we could rename another option for clarify? I think FAST (it's about some bw limits?) and WAIT (wait for what? checkpoint?) option names are confusing.
Could we replace FAST with "CHECKPOINT [fast|spread]" and WAIT to WAIT_WAL_ARCHIVED? I think such names would be more descriptive.

-		if (PQserverVersion(conn) >= 100000)
-			/* pg_recvlogical doesn't use an exported snapshot, so suppress */
-			appendPQExpBufferStr(query, " NOEXPORT_SNAPSHOT");
+		/* pg_recvlogical doesn't use an exported snapshot, so suppress */
+		if (use_new_option_syntax)
+			AppendStringCommandOption(query, use_new_option_syntax,
+									   "SNAPSHOT", "nothing");
+		else
+			AppendPlainCommandOption(query, use_new_option_syntax,
+									 "NOEXPORT_SNAPSHOT");

In 0002, it looks like condition for 9.x releases was lost?

Also my gcc version 8.3.0 is not happy with v5-0007-Support-base-backup-targets.patch and produces:

basebackup.c: In function ‘parse_basebackup_options’:
basebackup.c:970:7: error: ‘target_str’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
       errmsg("target '%s' does not accept a target detail",
       ^~~~~~

regards, Sergei





view thread (171+ messages)  latest in thread

Message-ID: <979131631633278@mail.yandex.ru>
Permalink:  ../979131631633278@mail.yandex.ru/
Also on:    postgresql.org/message-id/979131631633278@mail.yandex.ru

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: sk@zsrv.org, robertmhaas@gmail.com, dilipbalaut@gmail.com, jeevan.ladhe@enterprisedb.com, mark.dilger@enterprisedb.com, tushar.ahuja@enterprisedb.com
  Subject: Re: refactoring basebackup.c
  In-Reply-To: <979131631633278@mail.yandex.ru>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox