pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Amit Kapila <amit.kapila16@gmail.com>
To: Thom Brown <thom@linux.com>
Cc: Robert Haas <robertmhaas@gmail.com>
Cc: Simon Riggs <simon@2ndquadrant.com>
Cc: Jesper Pedersen <jesper.pedersen@redhat.com>
Cc: pgsql-hackers <pgsql-hackers@postgresql.org>
Subject: Re: Speed up Clog Access by increasing CLOG buffers
Date: Wed, 10 Feb 2016 09:44:53 +0530
Message-ID: <CAA4eK1JY4M+P9VT6VJkuNzO2CYYnc2eT08qRQ6cRYU0eUy2mVA@mail.gmail.com> (raw)
In-Reply-To: <CAA-aLv440-oCQmZD1E5cTRPUo6Ec1zeE1vYzwRHqpceRwrM7eg@mail.gmail.com>
References: <CAA4eK1+8=X9mSNeVeHg_NqMsOR-XKsjuqrYzQf=iCsdh3U4EOA@mail.gmail.com>
	<20150903114137.GE27649@awork2.anarazel.de>
	<CAA4eK1LMMGNQ439BUm0LcS3p0sb8S9kc-cUGU_ThNqMwA8_Tug@mail.gmail.com>
	<55FC4C33.1050903@redhat.com>
	<CAA4eK1LKw4zR6Mb5EQWsmRCyhxpeUakRrDyB1Gth6nw4ktw3iw@mail.gmail.com>
	<55FFFE51.1060308@redhat.com>
	<CAA4eK1L_snxM_JcrzEstNq9P66++F4kKFce=1r5+D1vzPofdtg@mail.gmail.com>
	<CANP8+jKGcCypXg6cTsAx=vOze81wHrEmEUPu9qWj8BfwvB9Thw@mail.gmail.com>
	<CAA4eK1LJmK=CfHf3xu+fPHMPzs6GYXON_Ni7LvncP7LddWaXWQ@mail.gmail.com>
	<CANP8+j+q4+ZP0JExgvDRPBpW6cDjb15nvjBR3iWmyoHH--3dCg@mail.gmail.com>
	<CAA4eK1+pgGLNuumZo6swNZGd1_=Sfve0fuT58JQ-KpYKF4064A@mail.gmail.com>
	<CANP8+j+hZ8ekC++eMGq33+MFiNrPNwc-GnBNfRdRjktDPd+G0g@mail.gmail.com>
	<CAA4eK1+_66KZxf8PA4xU21z7rhGz7==n7ytb-eVJWdhJDF+s+Q@mail.gmail.com>
	<CA+TgmoahCx6XgprR=p5==cF0g9uhSHsJxVdWdUEHN9H2Mv0gkw@mail.gmail.com>
	<CAA4eK1+VD=f0EPd_FoGX60ygWDguHDxu8DsrPDr_DS2yy4r88w@mail.gmail.com>
	<CA+TgmoaoBJ1s98OjOwTgH7XV5zJaHCRTvvg+tP1yJHk4z=reyA@mail.gmail.com>
	<CAA4eK1+SoW3FBrdZV+3m34uCByK3DMPy_9QQs34yvN8spByzyA@mail.gmail.com>
	<CA+TgmoanL8NwuZTnFxDeM5w+HLy1zuHZrtTMF99uM68ySxd2ew@mail.gmail.com>
	<CAA4eK1+Ebf4W7D74_1NfLZYEpUoXUKzxTjqxdankW0xMhqkLYw@mail.gmail.com>
	<CA+TgmobysOsEajkhvMdEGFMH4shcAneGTUNXnPd_O-_=f8ucSQ@mail.gmail.com>
	<CAA4eK1JCzEksmYYquxHrVP2-B_shsydg80TH3DOVy8u=bgZNwA@mail.gmail.com>
	<CA+Tgmoab1AOcR6Fwqe2cYZQ7LeyzyL+DaWE=t06Ya7_Ho5C2hw@mail.gmail.com>
	<CAA4eK1+5VvzD_u-Y504p-7SKdOUsiKikd8tfhVyziDQk93fwOw@mail.gmail.com>
	<CA+TgmoajjobHxBdORn_N9giVKdEDihz6_KsBXpbZjMY7RCo+=w@mail.gmail.com>
	<CAA4eK1K2RefbYcUAGuKAy4LLhGBV6a9DfnWnhp17++JEzVseqA@mail.gmail.com>
	<CAA-aLv440-oCQmZD1E5cTRPUo6Ec1zeE1vYzwRHqpceRwrM7eg@mail.gmail.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-hackers>

On Tue, Feb 9, 2016 at 7:26 PM, Thom Brown <thom@linux.com> wrote:
>
> On 7 January 2016 at 05:24, Amit Kapila <amit.kapila16@gmail.com> wrote:
> > On Fri, Dec 25, 2015 at 6:36 AM, Robert Haas <robertmhaas@gmail.com>
wrote:
> >>
> >> On Wed, Dec 23, 2015 at 1:16 AM, Amit Kapila <amit.kapila16@gmail.com>
> >> wrote:
> >> >> >
> >> >> > Here procArrayGroupXid sounds like Xid at group level, how about
> >> >> > procArrayGroupMemberXid?
> >> >> > Find the patch with renamed variables for PGProc
> >> >> > (rename_pgproc_variables_v1.patch) attached with mail.
> >> >>
> >> >> I sort of hate to make these member names any longer, but I wonder
if
> >> >> we should make it procArrayGroupClearXid etc.
> >> >
> >> > If we go by this suggestion, then the name will look like:
> >> > PGProc
> >> > {
> >> > ..
> >> > bool procArrayGroupClearXid, pg_atomic_uint32
> >> > procArrayGroupNextClearXid,
> >> > TransactionId procArrayGroupLatestXid;
> >> > ..
> >> >
> >> > PROC_HDR
> >> > {
> >> > ..
> >> > pg_atomic_uint32 procArrayGroupFirstClearXid;
> >> > ..
> >> > }
> >> >
> >> > I think whatever I sent in last patch were better.  It seems to me
it is
> >> > better to add some comments before variable names, so that anybody
> >> > referring them can understand better and I have added comments in
> >> > attached patch rename_pgproc_variables_v2.patch to explain the same.
> >>
> >> Well, I don't know.  Anybody else have an opinion?
> >>
> >
> > It seems that either people don't have any opinion on this matter or
they
> > are okay with either of the naming conventions being discussed.  I think
> > specifying Member after procArrayGroup can help distinguishing which
> > variables are specific to the whole group and which are specific to a
> > particular member.  I think that will be helpful for other places as
well
> > if we use this technique to improve performance.  Let me know what
> > you think about the same.
> >
> > I have verified that previous patches can be applied cleanly and passes
> > make check-world.  To avoid confusion, I am attaching the latest
> > patches with this mail.
>
> Patches still apply 1 month later.
>

Thanks for verification!

>
> I don't really have an opinion on the variable naming.  I guess they
> only need making longer if there's going to be some confusion about
> what they're for,

makes sense, that is the reason why I have added few comments
as well, but not sure if you are suggesting something else.

> but I'm guessing it's not a blocker here.
>

I also think so, but not sure what else is required here.  The basic
idea of this rename_pgproc_variables_v2.patch is to rename
few variables in existing similar code, so that the main patch
group_update_clog can adapt those naming convention if required,
other than that I have handled all review comments raised in this
thread (mainly by Simon and Robert).

Is there anything, I can do to move this forward?


With Regards,
Amit Kapila.
EnterpriseDB: http://www.enterprisedb.com

view thread (248+ messages)  latest in thread

Message-ID: <CAA4eK1JY4M+P9VT6VJkuNzO2CYYnc2eT08qRQ6cRYU0eUy2mVA@mail.gmail.com>
Permalink:  ../CAA4eK1JY4M+P9VT6VJkuNzO2CYYnc2eT08qRQ6cRYU0eUy2mVA@mail.gmail.com/
Also on:    postgresql.org/message-id/CAA4eK1JY4M+P9VT6VJkuNzO2CYYnc2eT08qRQ6cRYU0eUy2mVA@mail.gmail.com

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: amit.kapila16@gmail.com, thom@linux.com, robertmhaas@gmail.com, simon@2ndquadrant.com, jesper.pedersen@redhat.com
  Subject: Re: Speed up Clog Access by increasing CLOG buffers
  In-Reply-To: <CAA4eK1JY4M+P9VT6VJkuNzO2CYYnc2eT08qRQ6cRYU0eUy2mVA@mail.gmail.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox