public inbox for [email protected]
help / color / mirror / Atom feedFrom: Amit Kapila <[email protected]>
To: Masahiko Sawada <[email protected]>
Cc: Bertrand Drouvot <[email protected]>
Cc: Andres Freund <[email protected]>
Cc: Peter Smith <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: shveta malik <[email protected]>
Cc: Bharath Rupireddy <[email protected]>
Cc: [email protected]
Subject: Re: Add contrib/pg_logicalsnapinspect
Date: Fri, 7 Mar 2025 10:26:23 +0530
Message-ID: <CAA4eK1LGV8PME4KfZanF16gE1HDb+nPn06TTxv1OtV0466oJ-w@mail.gmail.com> (raw)
In-Reply-To: <CAD21AoBkdiq6Te7D_LtKDDB2WsZWBKWqWNVguhy9R_xAMf_xDg@mail.gmail.com>
References: <[email protected]>
<CAD21AoB31apHCzZ-45rDtB56qQm+TBwJnB48JjBvuqR5xviAEQ@mail.gmail.com>
<CAD21AoD+opO0SaDSFvz+n+wAxc-kUrpF5Wtxbw80Bqpay+rkgw@mail.gmail.com>
<CAHut+PsYdTW4+U+fioh9_yO8iT6RnY=PquzfCZu7zRU6Qg6W7g@mail.gmail.com>
<Zwy4ys76aPcoVE/[email protected]>
<CAD21AoDuO87MFrPJFwtmRi=cFhDGac0zq7sq5pdEhVi7zUvbEg@mail.gmail.com>
<5qbxud4pvnvmtuoi7weiizm5hmumxaeohx4vztfhrwlfhyz6rj@buh4435mllwo>
<CAD21AoBM6vAcPGR-ng0nqGG0yemR_ufdg3+v3gkPa6Nc2ntnrA@mail.gmail.com>
<[email protected]>
<CAA4eK1L0bZbZOr8-VNFXDfqaTwggdf_-HTAsneui+_ozMTvZQg@mail.gmail.com>
<Z8g9/GeoXv/[email protected]>
<CAD21AoBkdiq6Te7D_LtKDDB2WsZWBKWqWNVguhy9R_xAMf_xDg@mail.gmail.com>
On Fri, Mar 7, 2025 at 3:19 AM Masahiko Sawada <[email protected]> wrote:
>
> On Wed, Mar 5, 2025 at 4:05 AM Bertrand Drouvot
> <[email protected]> wrote:
> >
> > Hi,
> >
> > On Wed, Mar 05, 2025 at 02:42:15PM +0530, Amit Kapila wrote:
> > > On Wed, Mar 5, 2025 at 12:47 PM Bertrand Drouvot
> > > <[email protected]> wrote:
> > > >
> > > > Agree, PFA a patch doing so.
> > > >
> > >
> > > It would be better if you could add a few comments atop the
> > > permutation line to explain the working of the test.
> >
> > yeah makes sense. Done in the attached, and bonus point I realized that the
> > test could be simplified (so, removing useless steps in passing).
> >
>
> Thank you for the patch.
>
> The new simplified test case can be pretty-formatted as:
>
> init
> begin
> savepoint
> truncate
> checkpoint-1
> get_changes-1
> commit
> checkpoint-2
> get_changes-2
> info_catchange check
> info_committed check
> meta check
>
> IIUC if another checkpoint happens between get_change-2 and the
> subsequent checks, the first snapshot would be removed during the
> checkpoint, resulting in a test failure. I think we could check the
> snapshot files while one transaction keeps open. The more simplified
> test case would be:
>
> init
> begin
> savepoint
> insert(cat-change)
> begin
> insert(cat-change)
> commit
> checkpoint
> get_changes
> info_catchange check
> info_committed check
> meta check
> commit
>
> In this test case, we would have at least one serialized snapshot that
> has both cat-changes and committed txns. What do you think?
>
Your proposed change in the test sounds better than what we have now
but I think we should also avoid autovacuum to perform analyze as that
may add additional counts. For test_decoding, we keep
autovacuum_naptime = 1d in logical.conf file, we can either use the
same here or simply keep autovacuum off.
--
With Regards,
Amit Kapila.
view thread (38+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: Add contrib/pg_logicalsnapinspect
In-Reply-To: <CAA4eK1LGV8PME4KfZanF16gE1HDb+nPn06TTxv1OtV0466oJ-w@mail.gmail.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox