From: Peter Eisentraut <peter.eisentraut@enterprisedb.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
To: pgsql-hackers@lists.postgresql.org
Subject: Re: "debug_invalidate_system_caches_always" is too long
Date: Wed, 7 Jul 2021 10:37:15 +0200
Message-ID: <a813b3cc-36e6-8f58-273d-ed74be3086b3@enterprisedb.com> (raw)
In-Reply-To: <1374320.1625430433@sss.pgh.pa.us>
References: <1374320.1625430433@sss.pgh.pa.us>
On 04.07.21 22:27, Tom Lane wrote:
> I do agree with the "debug_" prefix given that it's now visible to
> users. However, it doesn't seem that hard to save some space in
> the rest of the name. The word "system" is adding nothing of value,
> and the word "always" seems rather confusing --- if it does
> something "always", why is there more than one level? So a simple
> proposal is to rename it to "debug_invalidate_caches".
I think we can definitely drop the "always". Not so much the "system",
since there are other caches, but it would be ok if we want it shorter.
> However, I think we should also give serious consideration to
> "debug_clobber_cache" or "debug_clobber_cache_always" for continuity
> with past practice (though it still feels like "always" is a good
> word to lose now). "debug_clobber_caches" is another reasonable
> variant.
The clobbering doesn't actually happen unless you turn on
CLOBBER_FREED_MEMORY, so it would be good to keep that separate.
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: peter.eisentraut@enterprisedb.com, tgl@sss.pgh.pa.us, pgsql-hackers@lists.postgresql.org
Subject: Re: "debug_invalidate_system_caches_always" is too long
In-Reply-To: <a813b3cc-36e6-8f58-273d-ed74be3086b3@enterprisedb.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox