From: Peter Eisentraut <peter.eisentraut@2ndquadrant.com>
To: Kyotaro HORIGUCHI <horiguchi.kyotaro@lab.ntt.co.jp>
Cc: pgsql-hackers@postgresql.org
Subject: Re: pg_stat_ssl additions
Date: Wed, 28 Nov 2018 18:31:59 +0100
Message-ID: <d8e4e6d9-4007-e115-86aa-8d5c2679696d@2ndquadrant.com> (raw)
In-Reply-To: <01e7dd28-6bcc-5c26-a77d-54340a51633f@2ndquadrant.com>
References: <398754d8-6bb5-c5cf-e7b8-22e5f0983caf@2ndquadrant.com>
<20181120.173122.55744021.horiguchi.kyotaro@lab.ntt.co.jp>
<01e7dd28-6bcc-5c26-a77d-54340a51633f@2ndquadrant.com>
On 20/11/2018 22:41, Peter Eisentraut wrote:
>>> - Adds new fields to pg_stat_ssl: issuerdn and clientserial. These
>>> allow uniquely identifying the client certificate. AFAICT, these are
>>> the most interesting pieces of information provided by sslinfo but not
>>> in pg_stat_ssl. (I don't like the underscore-free naming of these
>>> fields, but it matches the existing "clientdn".)
>> clientdn, clientserial, issuerdn are the fields about client
>> certificates. Only the last one omits prefixing "client". But
>> "clientissuerdn" seems somewhat rotten... Counldn't we rename
>> clientdn to client_dn?
> I'd prefer renaming as well, but some people might not like that.
Any thoughts from others about whether to rename clientdn to client_dn
to allow better naming of the new fields?
--
Peter Eisentraut http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: peter.eisentraut@2ndquadrant.com, horiguchi.kyotaro@lab.ntt.co.jp
Subject: Re: pg_stat_ssl additions
In-Reply-To: <d8e4e6d9-4007-e115-86aa-8d5c2679696d@2ndquadrant.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox