public inbox for [email protected]
help / color / mirror / Atom feedFrom: Peter Eisentraut <[email protected]>
To: Tom Lane <[email protected]>
Cc: Greg Sabino Mullane <[email protected]>
Cc: [email protected]
Cc: Magnus Hagander <[email protected]>
Subject: Re: Tarball builds in the new world order
Date: Fri, 3 May 2024 15:57:35 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
<CAKAnmmLS20mob0wWibo9ZNoMzxnP=LYN85dd41iy+KeuPN73+A@mail.gmail.com>
<[email protected]>
<[email protected]>
<[email protected]>
<[email protected]>
On 29.04.24 18:14, Tom Lane wrote:
> Peter Eisentraut <[email protected]> writes:
>> On 26.04.24 21:24, Tom Lane wrote:
>>> Concretely, I'm proposing the attached. Peter didn't like
>>> PG_COMMIT_HASH, so I have PG_COMMIT_REFSPEC below, but I'm not
>>> wedded to that if a better name is proposed.
>
>> This seems ok to me, but note that we do have an equivalent
>> implementation in meson. If we don't want to update that in a similar
>> way, maybe we should disable it.
>
> OK. After poking at that for awhile, it seemed like "default to
> HEAD" fits into meson a lot better than "throw an error if the
> variable isn't set", so I switched to doing it like that.
> One reason is that AFAICT you can only set the variable during
> "meson setup" not during "ninja". This won't matter to the
> tarball build script, which does a one-off configuration run
> anyway. But for manual use, a movable target like HEAD might be
> more convenient given that behavior.
This patch looks good to me.
view thread (9+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected], [email protected]
Subject: Re: Tarball builds in the new world order
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox