public inbox for [email protected]
help / color / mirror / Atom feed[PATCH 2/6] s/rewinded/rewound/
4+ messages / 3 participants
[nested] [flat]
* [PATCH 2/6] s/rewinded/rewound/
@ 2020-10-25 17:32 Justin Pryzby <[email protected]>
0 siblings, 0 replies; 4+ messages in thread
From: Justin Pryzby @ 2020-10-25 17:32 UTC (permalink / raw)
---
doc/src/sgml/ref/pg_rewind.sgml | 2 +-
src/bin/pg_rewind/parsexlog.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/doc/src/sgml/ref/pg_rewind.sgml b/doc/src/sgml/ref/pg_rewind.sgml
index 688acdcb06..43282e6016 100644
--- a/doc/src/sgml/ref/pg_rewind.sgml
+++ b/doc/src/sgml/ref/pg_rewind.sgml
@@ -74,7 +74,7 @@ PostgreSQL documentation
<application>pg_rewind</application> with the <literal>-c</literal> option to
automatically retrieve them from the WAL archive. The use of
<application>pg_rewind</application> is not limited to failover, e.g., a standby
- server can be promoted, run some write transactions, and then rewinded
+ server can be promoted, run some write transactions, and then rewound
to become a standby again.
</para>
diff --git a/src/bin/pg_rewind/parsexlog.c b/src/bin/pg_rewind/parsexlog.c
index 2229c86f9a..a2f1ab5422 100644
--- a/src/bin/pg_rewind/parsexlog.c
+++ b/src/bin/pg_rewind/parsexlog.c
@@ -207,7 +207,7 @@ findLastCheckpoint(const char *datadir, XLogRecPtr forkptr, int tliIndex,
/*
* Check if it is a checkpoint record. This checkpoint record needs to
* be the latest checkpoint before WAL forked and not the checkpoint
- * where the primary has been stopped to be rewinded.
+ * where the primary has been stopped to be rewound.
*/
info = XLogRecGetInfo(xlogreader) & ~XLR_INFO_MASK;
if (searchptr < forkptr &&
--
2.17.0
--SavPGzlo48F1Gxyz
Content-Type: text/x-diff; charset=us-ascii
Content-Disposition: attachment;
filename="0003-comparison-but-see-also-language-changed-at-35cb574a.patch"
^ permalink raw reply [nested|flat] 4+ messages in thread
* [PATCH v2 2/6] s/rewinded/rewound/
@ 2020-10-25 17:32 Justin Pryzby <[email protected]>
0 siblings, 0 replies; 4+ messages in thread
From: Justin Pryzby @ 2020-10-25 17:32 UTC (permalink / raw)
---
doc/src/sgml/ref/pg_rewind.sgml | 2 +-
src/bin/pg_rewind/parsexlog.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/doc/src/sgml/ref/pg_rewind.sgml b/doc/src/sgml/ref/pg_rewind.sgml
index 688acdcb06..43282e6016 100644
--- a/doc/src/sgml/ref/pg_rewind.sgml
+++ b/doc/src/sgml/ref/pg_rewind.sgml
@@ -74,7 +74,7 @@ PostgreSQL documentation
<application>pg_rewind</application> with the <literal>-c</literal> option to
automatically retrieve them from the WAL archive. The use of
<application>pg_rewind</application> is not limited to failover, e.g., a standby
- server can be promoted, run some write transactions, and then rewinded
+ server can be promoted, run some write transactions, and then rewound
to become a standby again.
</para>
diff --git a/src/bin/pg_rewind/parsexlog.c b/src/bin/pg_rewind/parsexlog.c
index 2229c86f9a..a2f1ab5422 100644
--- a/src/bin/pg_rewind/parsexlog.c
+++ b/src/bin/pg_rewind/parsexlog.c
@@ -207,7 +207,7 @@ findLastCheckpoint(const char *datadir, XLogRecPtr forkptr, int tliIndex,
/*
* Check if it is a checkpoint record. This checkpoint record needs to
* be the latest checkpoint before WAL forked and not the checkpoint
- * where the primary has been stopped to be rewinded.
+ * where the primary has been stopped to be rewound.
*/
info = XLogRecGetInfo(xlogreader) & ~XLR_INFO_MASK;
if (searchptr < forkptr &&
--
2.17.0
--QRj9sO5tAVLaXnSD
Content-Type: text/x-diff; charset=us-ascii
Content-Disposition: attachment; filename="v2-0003-others.patch"
^ permalink raw reply [nested|flat] 4+ messages in thread
* Re: Adding a pg_get_owned_sequence function?
@ 2023-10-24 16:29 Nathan Bossart <[email protected]>
2024-01-08 05:24 ` Re: Adding a pg_get_owned_sequence function? vignesh C <[email protected]>
0 siblings, 1 reply; 4+ messages in thread
From: Nathan Bossart @ 2023-10-24 16:29 UTC (permalink / raw)
To: Dagfinn Ilmari Mannsåker <[email protected]>; +Cc: Tom Lane <[email protected]>; Peter Eisentraut <[email protected]>; pgsql-hackers
On Tue, Sep 12, 2023 at 03:53:28PM +0100, Dagfinn Ilmari Mannsåker wrote:
> Tom Lane <[email protected]> writes:
>> It's possible that we could get away with just summarily changing
>> the argument type from text to regclass. ISTR that we did exactly
>> that with nextval() years ago, and didn't get too much push-back.
>> But we couldn't do the same for the return type. Also, this
>> approach does nothing for the concern about the name being
>> misleading.
>
> Maybe we should go all the way the other way, and call it
> pg_get_identity_sequence() and claim that "serial" is a legacy form of
> identity columns?
Hm. Could we split it into two functions, pg_get_owned_sequence() and
pg_get_identity_sequence()? I see that commit 3012061 [0] added support
for identity columns to pg_get_serial_sequence() because folks expected
that to work, so maybe that's a good reason to keep them together. If we
do elect to keep them combined, I'd be okay with renaming it to
pg_get_identity_sequence() along with your other proposed changes.
[0] https://postgr.es/m/20170912212054.25640.55202%40wrigleys.postgresql.org
--
Nathan Bossart
Amazon Web Services: https://aws.amazon.com
^ permalink raw reply [nested|flat] 4+ messages in thread
* Re: Adding a pg_get_owned_sequence function?
2023-10-24 16:29 Re: Adding a pg_get_owned_sequence function? Nathan Bossart <[email protected]>
@ 2024-01-08 05:24 ` vignesh C <[email protected]>
0 siblings, 0 replies; 4+ messages in thread
From: vignesh C @ 2024-01-08 05:24 UTC (permalink / raw)
To: Nathan Bossart <[email protected]>; +Cc: Dagfinn Ilmari Mannsåker <[email protected]>; Tom Lane <[email protected]>; Peter Eisentraut <[email protected]>; pgsql-hackers
On Tue, 24 Oct 2023 at 22:00, Nathan Bossart <[email protected]> wrote:
>
> On Tue, Sep 12, 2023 at 03:53:28PM +0100, Dagfinn Ilmari Mannsåker wrote:
> > Tom Lane <[email protected]> writes:
> >> It's possible that we could get away with just summarily changing
> >> the argument type from text to regclass. ISTR that we did exactly
> >> that with nextval() years ago, and didn't get too much push-back.
> >> But we couldn't do the same for the return type. Also, this
> >> approach does nothing for the concern about the name being
> >> misleading.
> >
> > Maybe we should go all the way the other way, and call it
> > pg_get_identity_sequence() and claim that "serial" is a legacy form of
> > identity columns?
>
> Hm. Could we split it into two functions, pg_get_owned_sequence() and
> pg_get_identity_sequence()? I see that commit 3012061 [0] added support
> for identity columns to pg_get_serial_sequence() because folks expected
> that to work, so maybe that's a good reason to keep them together. If we
> do elect to keep them combined, I'd be okay with renaming it to
> pg_get_identity_sequence() along with your other proposed changes.
I have changed the status of the patch to "Waiting on Author" as
Nathan's comments have not yet been followed up.
Regards,
Vignesh
^ permalink raw reply [nested|flat] 4+ messages in thread
end of thread, other threads:[~2024-01-08 05:24 UTC | newest]
Thread overview: 4+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2020-10-25 17:32 [PATCH 2/6] s/rewinded/rewound/ Justin Pryzby <[email protected]>
2020-10-25 17:32 [PATCH v2 2/6] s/rewinded/rewound/ Justin Pryzby <[email protected]>
2023-10-24 16:29 Re: Adding a pg_get_owned_sequence function? Nathan Bossart <[email protected]>
2024-01-08 05:24 ` Re: Adding a pg_get_owned_sequence function? vignesh C <[email protected]>
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox