public inbox for [email protected]
help / color / mirror / Atom feedFrom: Andres Freund <[email protected]>
To: Peter Eisentraut <[email protected]>
Cc: [email protected]
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
Date: Thu, 9 Apr 2026 10:40:30 -0400
Message-ID: <ovpakrvg3mfwyumhkrxjgnwfb75jo534booip7pqrq7cjt4orj@vydvdlbscnx4> (raw)
In-Reply-To: <[email protected]>
References: <bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg>
<[email protected]>
Hi,
On 2026-04-09 02:00:37 +0200, Peter Eisentraut wrote:
> On 08.04.26 23:09, Andres Freund wrote:
> > Hi,
> >
> > When reviewing the index prefetching patch I got a bit dismayed at how long
> > pg_attribute_always_inline is due to the way it triggers pgindent to format
> > stuff.
> >
> > I propose that we remove the _attribute_ part of the name.
> >
> > Given that it is implemented for compilers that don't use the
> > __attribute__((always_inline)) spelling, so the shorter name seems better
> > anyway.
>
> Yes, and the existing name is also kind of wrong even on GCC because the
> macro does not expand to only an attribute but also includes the "inline".
It didn't start out that way, that only came in a bit later, in
434e6e148441...
Created a CF entry, to reduce the chances of me forgetting about committing
this early in the 20 cycle.
Greetings,
Andres Freund
view thread (11+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected]
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
In-Reply-To: <ovpakrvg3mfwyumhkrxjgnwfb75jo534booip7pqrq7cjt4orj@vydvdlbscnx4>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox