agora inbox for pgsql-interfaces@postgresql.org
help / color / mirror / Atom feedFrom: Stephen Davies <sdavies@sdc.com.au>
To: pgsql-interfaces@postgresql.org
Subject: V9.3 Migration issues
Date: Mon, 06 Oct 2014 14:55:04 +1030
Message-ID: <543219A0.7030804@sdc.com.au> (raw)
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-interfaces>
Hello.
I am in the process of migrating several PostgreSQL databases from a 32-bit
V9.1.4 environment to a 64-bit V9.3 environment and have a couple of problems.
I have used pg_dump and pg_restore (or postgis_restore.pl) as required by the
combination of version and word size migration and the results have been
(superficially) good.
However,
1. Some tables in some databases have lost access privileges.
That is, users who could access tables on the old server are denied access on
the new.
I have fixed this by manually granting access where necessary but wonder
whether the original issue is a bug or something that I have missed in the
migration.
2. All CGI bash scripts now give:
[Sat Oct 04 16:45:14.439606 2014] [cgi:error] [pid 12696] [client
192.168.0.7:1556] AH01215: psql: could not connect to server: No such file or
directory, referer: http://192.168.0.200/jobs/jobs
[Sat Oct 04 16:45:14.439641 2014] [cgi:error] [pid 12696] [client
192.168.0.7:1556] AH01215: \tIs the server running locally and accepting,
referer: http://192.168.0.200/jobs/jobs
[Sat Oct 04 16:45:14.439658 2014] [cgi:error] [pid 12696] [client
192.168.0.7:1556] AH01215: \tconnections on Unix domain socket
"/tmp/.s.PGSQL.5432"?, referer: http://192.168.0.200/jobs/jobs
The socket /tmp/.s.PGSQL.5432 exists and has 777 permissions and executing the
same scripts from the command line works perfectly.
Presumably there is a permissions or configuration issue here but I cannot see it.
Any advice gratefully received.
Cheers and thanks,
Stephen
PS. Java programs, Tomcat servlets and TCP psql connections on/to the same box
also work perfectly.
--
=============================================================================
Stephen Davies Consulting P/L Phone: 08-8177 1595
Adelaide, South Australia. Mobile:040 304 0583
Records & Collections Management.
--
Sent via pgsql-interfaces mailing list (pgsql-interfaces@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-interfaces
view thread (2+ messages)
Message-ID: <543219A0.7030804@sdc.com.au>
Permalink: ../543219A0.7030804@sdc.com.au/
Also on: postgresql.org/message-id/543219A0.7030804@sdc.com.au
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-interfaces@postgresql.org
Cc: sdavies@sdc.com.au
Subject: Re: V9.3 Migration issues
In-Reply-To: <543219A0.7030804@sdc.com.au>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox