pg.ddx.io  pgsql-admin@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Laurenz Albe <laurenz.albe@cybertec.at>
To: prathap vathuluru <prathap.vathuluru@outlook.com>
To: pgsql-admin@lists.postgresql.org <pgsql-admin@lists.postgresql.org>
Subject: Re:  Error LOG:  could not receive data from client: Connection reset by peer
Date: Thu, 22 Jun 2023 15:51:22 +0200
Message-ID: <ff9f047cdc1595e8d7604f5c3a446e98aeb48930.camel@cybertec.at> (raw)
In-Reply-To: <MAXPR01MB3328F773227E6C76B06CF21BFC22A@MAXPR01MB3328.INDPRD01.PROD.OUTLOOK.COM>
References: <MAXPR01MB3328F773227E6C76B06CF21BFC22A@MAXPR01MB3328.INDPRD01.PROD.OUTLOOK.COM>

On Thu, 2023-06-22 at 09:56 +0000, prathap vathuluru wrote:
> I am seeing the below error message in My PostgreSQL Error log and My client is unable to connect to Database .
> 
> DB Level Log :
> 
> 2023-06-22 09:30:10 UTC 192.168.0.60(22237) [29452-1] XXXXXX@XXXXXX LOG:  could not receive data from client: Connection reset
>  by peer.
> 
> Application level Error :
> 
> Wed Jun 21 14:53:18 CEST 2023
> SQL Error [08006]: An I/O error occurred while sending to the backend.
> 
> Could you please , Suggest relevant resolution for the Above issue ., We have 5 databases with enough resources in the same cluster .

Usually, it is a network problem.

Try to adjust the TCP keepalive settings:

https://www.cybertec-postgresql.com/en/tcp-keepalive-for-a-better-postgresql-experience/

Yours,
Laurenz Albe





view thread (2+ messages)

Message-ID: <ff9f047cdc1595e8d7604f5c3a446e98aeb48930.camel@cybertec.at>
Permalink:  ../ff9f047cdc1595e8d7604f5c3a446e98aeb48930.camel@cybertec.at/
Also on:    postgresql.org/message-id/ff9f047cdc1595e8d7604f5c3a446e98aeb48930.camel@cybertec.at

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-admin@postgresql.org
  Cc: laurenz.albe@cybertec.at, prathap.vathuluru@outlook.com, pgsql-admin@lists.postgresql.org
  Subject: Re:  Error LOG:  could not receive data from client: Connection reset by peer
  In-Reply-To: <ff9f047cdc1595e8d7604f5c3a446e98aeb48930.camel@cybertec.at>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox