From: Tom Lane <tgl@sss.pgh.pa.us>
To: Álvaro Herrera <alvherre@kurilemu.de>
Cc: d.kovalenko@postgrespro.ru
Cc: pgsql-bugs@lists.postgresql.org
Subject: Re: BUG #18960: Mistake in test test_simple_pipeline (libpq_pipeline.c)
Date: Wed, 03 Sep 2025 16:10:52 -0400
Message-ID: <901577.1756930252@sss.pgh.pa.us> (raw)
In-Reply-To: <202509031706.ojnhzuyakuo4@alvherre.pgsql>
References: <202509031706.ojnhzuyakuo4@alvherre.pgsql>
=?utf-8?Q?=C3=81lvaro?= Herrera <alvherre@kurilemu.de> writes:
> On 2025-Sep-03, Tom Lane wrote:
>> Hm, I chose that name by analogy to the adjacent
>> confirm_query_canceled(), which is likewise consuming a result.
>> I agree that "consume" is a better verb, but then let's rename
>> confirm_query_canceled as well.
> Ah, that explains it -- my bad, then, I suppose. That change works for
> me.
After reflection, I used "consume_xxx" for the void-returning helper
functions, but kept the "confirm_xxx" terminology for the helper
function that returns a PGresult after confirming its status is
as-expected. Pushed with those renamings.
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-bugs@postgresql.org
Cc: tgl@sss.pgh.pa.us, alvherre@kurilemu.de, d.kovalenko@postgrespro.ru, pgsql-bugs@lists.postgresql.org
Subject: Re: BUG #18960: Mistake in test test_simple_pipeline (libpq_pipeline.c)
In-Reply-To: <901577.1756930252@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox