From: Álvaro Herrera <alvherre@kurilemu.de>
To: Andrew Dunstan <andrew@dunslane.net>
To: Mahendra Singh Thalor <mahi6run@gmail.com>
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
Date: Mon, 14 Apr 2025 14:20:10 +0200
Message-ID: <202504141220.343fmoxfsbj4@alvherre.pgsql> (raw)
In-Reply-To: <E1u0nMP-002gkh-0E@gemulon.postgresql.org>
On 2025-Apr-04, Andrew Dunstan wrote:
> Non text modes for pg_dumpall, correspondingly change pg_restore
I think the new oid_string_list stuff in this commit is unnecessary, and
we can remove a bunch of lines by simplifying that to using
SimplePtrList, as the attached illustrates. (Perhaps the names of
members of the proposed struct can be improved.)
I also propose to remove the open-coded implementation of pg_get_line.
WDYT?
I'm also not sure about the double sscanf() business there ... There
must be a better way to do this.
--
Álvaro Herrera Breisgau, Deutschland — https://www.EnterpriseDB.com/Attachments:
0001-remove-unnecessary-oid_string-list-stuff.patch (text/x-diff, 0B) download
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-committers@postgresql.org
Cc: alvherre@kurilemu.de, andrew@dunslane.net, mahi6run@gmail.com, pgsql-hackers@lists.postgresql.org
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
In-Reply-To: <202504141220.343fmoxfsbj4@alvherre.pgsql>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox