From: Andrew Dunstan <andrew@dunslane.net>
To: Álvaro Herrera <alvherre@kurilemu.de>
To: Mahendra Singh Thalor <mahi6run@gmail.com>
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
Date: Mon, 14 Apr 2025 12:28:15 -0400
Message-ID: <6e0e57e5-ace5-4d18-b1c1-7a3b3da36316@dunslane.net> (raw)
In-Reply-To: <202504141220.343fmoxfsbj4@alvherre.pgsql>
References: <202504141220.343fmoxfsbj4@alvherre.pgsql>
On 2025-04-14 Mo 8:20 AM, Álvaro Herrera wrote:
> On 2025-Apr-04, Andrew Dunstan wrote:
>
>> Non text modes for pg_dumpall, correspondingly change pg_restore
> I think the new oid_string_list stuff in this commit is unnecessary, and
> we can remove a bunch of lines by simplifying that to using
> SimplePtrList, as the attached illustrates. (Perhaps the names of
> members of the proposed struct can be improved.)
Sure, we can do it that way.
>
> I also propose to remove the open-coded implementation of pg_get_line.
>
> WDYT?
seems reasonable
>
> I'm also not sure about the double sscanf() business there ... There
> must be a better way to do this.
Yes, probably. I'll look into that if you like.
cheers
andrew
--
Andrew Dunstan
EDB: https://www.enterprisedb.com
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-committers@postgresql.org
Cc: andrew@dunslane.net, alvherre@kurilemu.de, mahi6run@gmail.com, pgsql-hackers@lists.postgresql.org
Subject: Re: pgsql: Non text modes for pg_dumpall, correspondingly change pg_restore
In-Reply-To: <6e0e57e5-ace5-4d18-b1c1-7a3b3da36316@dunslane.net>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox