From: Alvaro Herrera <alvherre@2ndquadrant.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
Cc: Andres Freund <andres@anarazel.de>
Cc: Pg Hackers <pgsql-hackers@lists.postgresql.org>
Subject: Re: adding strndup
Date: Wed, 4 Dec 2019 16:05:01 -0300
Message-ID: <20191204190501.GA29287@alvherre.pgsql> (raw)
In-Reply-To: <27820.1575485929@sss.pgh.pa.us>
On 2019-Dec-04, Tom Lane wrote:
> Andres Freund <andres@anarazel.de> writes:
> > On 2019-12-04 11:40:21 -0300, Alvaro Herrera wrote:
> >> I think this should be pretty uncontroversial, but wanted to give a
> >> heads-up outside that thread. I attach the patch here for completeness.
>
> > I'd just provide pnstrdup() in the frontend, without adding strndup().
>
> +1 --- seems like a bunch more mechanism than is warranted. Let's
> just open-code it in pnstrdup. We can rely on strnlen, since that's
> already supported, and there's not much more there beyond that.
I can get behind that ... it makes the patch a lot smaller. I'm gonna
send an updated version in a jiffy.
> > I also see no point in adding both pnstrdup() and pg_strndup(). I'm fine
> > with moving towards pg_strndup(), but then we just ought to remove
> > pnstrdup().
>
> There's a fair number of uses of pnstrdup in the backend. While it
> wouldn't be too painful to rename them, I'm not sure I see the point.
> (What I'd really argue for, if we did rename, is "pstrndup".)
*shrug* I also looked for pstrndup() first. And Peter E also in
https://postgr.es/m/1339713732.11971.79.camel@vanquo.pezone.net
submitted an implementation of pstrndup(). I'm not opposed to renaming
it, but I hesitate to do it at the same time as putting it in pgport.
--
Álvaro Herrera https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: alvherre@2ndquadrant.com, tgl@sss.pgh.pa.us, andres@anarazel.de, pgsql-hackers@lists.postgresql.org
Subject: Re: adding strndup
In-Reply-To: <20191204190501.GA29287@alvherre.pgsql>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox