pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Justin Pryzby <pryzby@telsasoft.com>
To: Michael Paquier <michael@paquier.xyz>
Cc: Alvaro Herrera <alvherre@2ndquadrant.com>
Cc: Andres Freund <andres@anarazel.de>
Cc: pgsql-hackers@postgresql.org
Subject: Re: error context for vacuum to include block number
Date: Sun, 15 Dec 2019 10:27:12 -0600
Message-ID: <20191215162712.GZ2082@telsasoft.com> (raw)
In-Reply-To: <20191215130708.GA19063@paquier.xyz>
References: <20191211165425.4ewww2s5k5cafi4l@alap3.anarazel.de>
	<20191211153353.GA23008@alvherre.pgsql>
	<20191213030831.GT2082@telsasoft.com>
	<20191213132850.GA103520@paquier.xyz>
	<20191213224735.GY2082@telsasoft.com>
	<20191215130708.GA19063@paquier.xyz>

On Sun, Dec 15, 2019 at 10:07:08PM +0900, Michael Paquier wrote:
> On Fri, Dec 13, 2019 at 04:47:35PM -0600, Justin Pryzby wrote:
> > It's related code which I cleaned up before adding new stuff.  Not essential,
> > thus separate (0002 should be backpatched).
> 
> The issue just causes some extra work and that's not a bug, so applied
> without a backpatch.

Thanks

> For 0003, I think that lazy_vacuum_heap_index() can be confusing as
> those indexes are unrelated to heap.  Why not naming it just
> lazy_vacuum_all_indexes()?  The routine should also have a header
> describing it.

I named it so because it calls both lazy_vacuum_index
("PROGRESS_VACUUM_PHASE_VACUUM_INDEX") and
lazy_vacuum_heap("PROGRESS_VACUUM_PHASE_VACUUM_HEAP")

I suppose you don't think the other way around is better?
lazy_vacuum_index_heap

Justin





view thread (139+ messages)  latest in thread

Message-ID: <20191215162712.GZ2082@telsasoft.com>
Permalink:  ../20191215162712.GZ2082@telsasoft.com/
Also on:    postgresql.org/message-id/20191215162712.GZ2082@telsasoft.com

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: pryzby@telsasoft.com, michael@paquier.xyz, alvherre@2ndquadrant.com, andres@anarazel.de
  Subject: Re: error context for vacuum to include block number
  In-Reply-To: <20191215162712.GZ2082@telsasoft.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox