From: Alvaro Herrera <alvherre@2ndquadrant.com>
To: Michael Paquier <michael@paquier.xyz>
Cc: Postgres hackers <pgsql-hackers@lists.postgresql.org>
Cc: Thomas Munro <thomas.munro@gmail.com>
Subject: Re: pg_stat_wal_receiver and flushedUpto/writtenUpto
Date: Fri, 15 May 2020 13:43:11 -0400
Message-ID: <20200515174311.GA2699@alvherre.pgsql> (raw)
In-Reply-To: <20200515090817.GA212736@paquier.xyz>
On 2020-May-15, Michael Paquier wrote:
> As discussed in the thread that introduced d140f2f3 to rename
> receivedUpto to flushedUpto and add writtenUpto to the WAL receiver's
> shared memory information, the equivalent columns in
> pg_stat_wal_receiver have not been renamed:
> When I have implemented this system view, the idea was to keep a
> one-one mapping between the SQL interface and the shmem info even if
> we are not compatible with past versions, hence I think that before
> beta1 we had better fix that and:
> - rename received_lsn to flushed_lsn.
> - add one column for writtenUpto.
Why do you put the column at the end? I would put written_lsn before
flushed_lsn.
Since this requires a catversion bump, I think it'd be best to do it
before beta1 next week.
--
Álvaro Herrera https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: alvherre@2ndquadrant.com, michael@paquier.xyz, pgsql-hackers@lists.postgresql.org, thomas.munro@gmail.com
Subject: Re: pg_stat_wal_receiver and flushedUpto/writtenUpto
In-Reply-To: <20200515174311.GA2699@alvherre.pgsql>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox