pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Tomas Vondra <tomas.vondra@2ndquadrant.com>
To: Julien Rouhaud <rjuju123@gmail.com>
Cc: Peter Eisentraut <peter.eisentraut@2ndquadrant.com>
Cc: pgsql-hackers <pgsql-hackers@postgresql.org>
Subject: Re: suggest to rename enable_incrementalsort
Date: Sun, 21 Jun 2020 13:21:59 +0200
Message-ID: <20200621112159.qtgedtrqw2c47pm4@development> (raw)
In-Reply-To: <CAOBaU_bsOKEXgF_ik3bjAfV7HQAM+2MTbAwtKujqiu1YueeUiQ@mail.gmail.com>
References: <df652910-e985-9547-152c-9d4357dc3979@2ndquadrant.com>
	<CAOBaU_bsOKEXgF_ik3bjAfV7HQAM+2MTbAwtKujqiu1YueeUiQ@mail.gmail.com>

On Sun, Jun 21, 2020 at 09:05:32AM +0200, Julien Rouhaud wrote:
>On Sun, Jun 21, 2020 at 8:26 AM Peter Eisentraut
><peter.eisentraut@2ndquadrant.com> wrote:
>>
>> I suggest to rename enable_incrementalsort to enable_incremental_sort.
>> This is obviously more readable and also how we have named recently
>> added multiword planner parameters.
>>
>> See attached patch.
>
>+1, this is a way better name (and patch LGTM on REL_13_STABLE).
>

The reason why I kept the single-word variant is consistency with other
GUCs that affect planning, like enable_indexscan, enable_hashjoin and
many others.

That being said, I'm not particularly attached this choice, so if you
think this is better I'm OK with it.


regards

-- 
Tomas Vondra                  http://www.2ndQuadrant.com
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services





view thread (14+ messages)  latest in thread

Message-ID: <20200621112159.qtgedtrqw2c47pm4@development>
Permalink:  ../20200621112159.qtgedtrqw2c47pm4@development/
Also on:    postgresql.org/message-id/20200621112159.qtgedtrqw2c47pm4@development

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: tomas.vondra@2ndquadrant.com, rjuju123@gmail.com, peter.eisentraut@2ndquadrant.com
  Subject: Re: suggest to rename enable_incrementalsort
  In-Reply-To: <20200621112159.qtgedtrqw2c47pm4@development>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox