pg.ddx.io pgsql-hackers@postgresql.org mailing list archive
help / color / mirror / Atom feed From: Nathan Bossart <nathandbossart@gmail.com>
To: John Naylor <john.naylor@enterprisedb.com>
Cc: Andres Freund <andres@anarazel.de>
Cc: Tom Lane <tgl@sss.pgh.pa.us>
Cc: Jelte Fennema <Jelte.Fennema@microsoft.com>
Cc: pgsql-hackers@postgresql.org <pgsql-hackers@postgresql.org>
Cc: Merlin Moncure <mmoncure@gmail.com>
Cc: Andrew Dunstan <andrew.dunstan@2ndquadrant.com>
Cc: Stephen Frost <sfrost@snowman.net>
Subject: Re: [PATCH] Optimize json_lex_string by batching character copying
Date: Fri, 19 Aug 2022 13:42:15 -0700
Message-ID: <20220819204215.GA397534@nathanxps13> (raw )
In-Reply-To: <CAFBsxsF8asF=qa2toXOceBgAYoKtftkL7tmE-WmCWxW-CRkeQg@mail.gmail.com >
References: <CAFBsxsGhaR2KQ5eisaK=6Vm60t=axhD8Ckj1qFoCH1pktZi+2w@mail.gmail.com >
<20220706051801.gfbzjxgflbsglyt6@awork3.anarazel.de >
<CAFBsxsE0FkMT0vZOLfJEOCM1Di81Wy_5fE9S1rn0PNHMYrmCCw@mail.gmail.com >
<20220711154150.hwzw7qw2k6iahofy@awork3.anarazel.de >
<1119852.1657554806@sss.pgh.pa.us >
<20220711160728.tljbnowfgxefdbli@awork3.anarazel.de >
<CAFBsxsGzaaGLF=Nuq61iRXTyspbO9rOjhSqFN=V6ozzmta5mXg@mail.gmail.com >
<CAFBsxsESLUyJ5spfOSyPrOvKUEYYNqsBosue9SV1j8ecgNXSKA@mail.gmail.com >
<20220815212304.GA251709@nathanxps13 >
<CAFBsxsF8asF=qa2toXOceBgAYoKtftkL7tmE-WmCWxW-CRkeQg@mail.gmail.com >
On Fri, Aug 19, 2022 at 03:11:36PM +0700, John Naylor wrote:
> This is done. Also:
> - a complete overhaul of the pg_lfind8* tests
> - using a typedef for the vector type
> - some refactoring, name changes and other cleanups (a few of these
> could also be applied to the 32-byte element path, but that is left
> for future work)
>
> TODO: json-specific tests of the new path
This looks pretty good to me. Should we rename vector_broadcast() and
vector_has_zero() to indicate that they are working with bytes (e.g.,
vector_broadcast_byte())? We might be able to use vector_broadcast_int()
in the 32-bit functions, and your other vector functions already have a
_byte suffix.
In general, the approach you've taken seems like a decent readability
improvement. I'd be happy to try my hand at adjusting the 32-bit path and
adding ARM versions of all this stuff.
--
Nathan Bossart
Amazon Web Services: https://aws.amazon.com
view thread (37+ messages) latest in thread
Message-ID: <20220819204215.GA397534@nathanxps13>
Permalink: ../20220819204215.GA397534@nathanxps13/
Also on: postgresql.org/message-id/20220819204215.GA397534@nathanxps13
copy link · copy postgr.es
reply Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: nathandbossart@gmail.com, john.naylor@enterprisedb.com, andres@anarazel.de, tgl@sss.pgh.pa.us, Jelte.Fennema@microsoft.com, mmoncure@gmail.com, andrew.dunstan@2ndquadrant.com, sfrost@snowman.net
Subject: Re: [PATCH] Optimize json_lex_string by batching character copying
In-Reply-To: <20220819204215.GA397534@nathanxps13>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox