From: Tom Lane <tgl@sss.pgh.pa.us>
To: Pavel Raiskup <praiskup@redhat.com>
Cc: Robert Haas <robertmhaas@gmail.com>
Cc: pgsql-hackers@postgresql.org <pgsql-hackers@postgresql.org>
Cc: Devrim GÜNDÜZ <devrim@gunduz.org>
Subject: Re: plruby: rb_iterate symbol clash with libruby.so
Date: Tue, 06 Nov 2018 13:28:21 -0500
Message-ID: <28762.1541528901@sss.pgh.pa.us> (raw)
In-Reply-To: <22881.1541515786@sss.pgh.pa.us>
References: <4738198.8KVIIDhgEB@nb.usersys.redhat.com>
<20461.1541269186@sss.pgh.pa.us>
<CA+TgmoYbguBrde0XrXpdHkFZcB3Bjc+oeR2T8Xjb1k+rzJCrPQ@mail.gmail.com>
<1772202.Bn4MKCBuZf@nb.usersys.redhat.com>
<22881.1541515786@sss.pgh.pa.us>
I wrote:
> Yeah. The long and short of this is that we're trampling on namespace
> that reasonably belongs to Ruby --- if they had some functions named
> "pg_something" and complained about a collision with libpq, would we
> change? Nope. So really we should rename these.
> Barring objections I'll go make this happen shortly.
Done. I realized that the immediate problem, rb_iterate(), was only
added as of PG v10, which may explain why we hadn't heard complaints
about this till now. So I've made the change only as far back as v10.
In principle we could change the rbtree code in 9.5/9.6 as well, but
I think that's more likely to create problems than fix any.
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, praiskup@redhat.com, robertmhaas@gmail.com, devrim@gunduz.org
Subject: Re: plruby: rb_iterate symbol clash with libruby.so
In-Reply-To: <28762.1541528901@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox