public inbox for [email protected]
help / color / mirror / Atom feedFrom: Tomas Vondra <[email protected]>
To: Peter Geoghegan <[email protected]>
Cc: Andres Freund <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: [email protected]
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
Date: Wed, 8 Jul 2026 23:41:47 +0200
Message-ID: <[email protected]> (raw)
In-Reply-To: <CAH2-Wzm3ev6uGsf4QddpaZamzsb3ATvanggEHxnhRSkdd52bnA@mail.gmail.com>
References: <bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg>
<[email protected]>
<ovpakrvg3mfwyumhkrxjgnwfb75jo534booip7pqrq7cjt4orj@vydvdlbscnx4>
<CAH2-WznHSUJcV47OhoisvABjN2xjVOYh0_bRagUE6ir5zGJzow@mail.gmail.com>
<[email protected]>
<CAH2-Wzm3ev6uGsf4QddpaZamzsb3ATvanggEHxnhRSkdd52bnA@mail.gmail.com>
On 6/12/26 18:10, Peter Geoghegan wrote:
> On Fri, Jun 12, 2026 at 11:23 AM Tomas Vondra <[email protected]> wrote:
>> I'm not sure about pg_mustinline. It seems weird to me, and I'm not sure
>> saving the 3 characters is worth it, pg_always_inline seems better.
>
> I'm not going to make a fuss about it.
>
>> Yeah, we should not do such weird stuff just because of unnecessarily
>> long attribute names.
>
> Right. Basically, I don't want to be told that I must completely
> change the order of function definitions because I used
> pg_[attribute]_always_inline. It's just not reasonable to impose that
> requirement on patch authors.
>
>> Question - do we plan to do this in master only, or was the plan to
>> backpatch the change? I'm not sure if these labels are used outside the
>> core code, that might be an issue for backpatching.
>
> I think that we should bite the bullet and backpatch. I count only 17
> instances of pg_attribute_always_inline on the master branch.
>
> Some extensions will no longer build against the backbranches if we go
> this way. However, extension authors should find it easy to work
> around this on an ad-hoc basis. They're going to have to work around
> it sooner or later, so we might as well favor the new spelling.
>
So, what shall we do about this? I've been looking at the v29 of the
index prefetching patch series, which is using this attribute in a bunch
of places. And that reminded me of this thread.
I guess we should just commit that, so unless someone objects soon I'll
just do that. ISTM the agreement is to backpatch this too.
regards
--
Tomas Vondra
view thread (11+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
In-Reply-To: <[email protected]>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox