public inbox for [email protected]
help / color / mirror / Atom feedFrom: Peter Geoghegan <[email protected]>
To: Andres Freund <[email protected]>
Cc: Peter Eisentraut <[email protected]>
Cc: [email protected]
Cc: Tomas Vondra <[email protected]>
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
Date: Wed, 27 May 2026 15:17:20 -0700
Message-ID: <CAH2-WznHSUJcV47OhoisvABjN2xjVOYh0_bRagUE6ir5zGJzow@mail.gmail.com> (raw)
In-Reply-To: <ovpakrvg3mfwyumhkrxjgnwfb75jo534booip7pqrq7cjt4orj@vydvdlbscnx4>
References: <bqqdehahpoa36igpictuqyn2s2mexk3t3ehidh2ffd2slb35e5@rzgksuiszgbg>
<[email protected]>
<ovpakrvg3mfwyumhkrxjgnwfb75jo534booip7pqrq7cjt4orj@vydvdlbscnx4>
On Thu, Apr 9, 2026 at 10:40 AM Andres Freund <[email protected]> wrote:
> Created a CF entry, to reduce the chances of me forgetting about committing
> this early in the 20 cycle.
We already have a pg_noinline. How about renaming
pg_attribute_always_inline to pg_mustinline? That is an alternative
that is both consistent with pg_noinline, and even terser than your
proposal.
I have no intention of holding this patch up with bikeshedding. But I
noticed that even your proposed pg_always_inline rename still leaves
function prototypes over the column limit with moderately verbose
function names. It seems better to avoid that outcome.
--
Peter Geoghegan
view thread (11+ messages) latest in thread
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: [email protected]
Cc: [email protected], [email protected], [email protected], [email protected]
Subject: Re: s/pg_attribute_always_inline/pg_always_inline/?
In-Reply-To: <CAH2-WznHSUJcV47OhoisvABjN2xjVOYh0_bRagUE6ir5zGJzow@mail.gmail.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox