From: Tom Lane <tgl@sss.pgh.pa.us>
To: Daniel Verite <daniel@manitou-mail.org>
Cc: Fabien COELHO <coelho@cri.ensmp.fr>
Cc: Robert Haas <robertmhaas@gmail.com>
Cc: Pavel Stehule <pavel.stehule@gmail.com>
Cc: Corey Huinker <corey.huinker@gmail.com>
Cc: PostgreSQL Developers <pgsql-hackers@postgresql.org>
Subject: Re: Variable substitution in psql backtick expansion
Date: Mon, 04 Sep 2017 13:35:40 -0400
Message-ID: <5956.1504546540@sss.pgh.pa.us> (raw)
In-Reply-To: <22a8687d-c192-4bdc-8d4b-053a094d641b@manitou-mail.org>
References: <22a8687d-c192-4bdc-8d4b-053a094d641b@manitou-mail.org>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-hackers>
"Daniel Verite" <daniel@manitou-mail.org> writes:
> The two-space left margin on the entire block does not add that
> much to readability, IMV, so maybe we could reclaim these
> two characters.
Well, it's a sub-list of the entire output of helpVariables(), so
I think some indentation is a good idea.
> That would look like the following, for example, with a 3-space margin
> for the description:
> AUTOCOMMIT
> If set, successful SQL commands are automatically committed
But we could do something close to that, say two-space indent for the
variable names and four-space for the descriptions.
> To me that looks like a good trade-off: it eases the size constraints
> for both the description and the name of the variable, at the cost
> of consuming one more line per variable, but that's why the pager
> is for.
Yeah, we're already past the point where it's likely that
helpVariables()'s output would fit on one screen for anybody, so
maybe this is the best way.
regards, tom lane
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, daniel@manitou-mail.org, coelho@cri.ensmp.fr, robertmhaas@gmail.com, pavel.stehule@gmail.com, corey.huinker@gmail.com
Subject: Re: Variable substitution in psql backtick expansion
In-Reply-To: <5956.1504546540@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox