From: Fujii Masao <masao.fujii@oss.nttdata.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
Cc: Hayato Kuroda (Fujitsu) <kuroda.hayato@fujitsu.com>
Cc: Andy Fan <zhihuifan1213@163.com>
Cc: Michael Paquier <michael@paquier.xyz>
Cc: PostgreSQL Hackers <pgsql-hackers@postgresql.org>
Subject: Re: A assert failure when initdb with track_commit_timestamp=on
Date: Sun, 6 Jul 2025 01:57:36 +0900
Message-ID: <75d59502-b571-4df8-9269-fd07cee52dd4@oss.nttdata.com> (raw)
In-Reply-To: <262595.1751649473@sss.pgh.pa.us>
References: <87plejmnpy.fsf@163.com>
<1f8f703d-72e8-4d05-ab16-ff0403a1d19d@oss.nttdata.com>
<aGXZL0oraweaENrF@paquier.xyz>
<OSCPR01MB14966207D000875CA4F4C9FEAF543A@OSCPR01MB14966.jpnprd01.prod.outlook.com>
<87o6u19z9w.fsf@163.com>
<3694f39a-7148-4197-91fe-25f3d01222b7@oss.nttdata.com>
<OSCPR01MB1496673E2FC58836331748DB6F542A@OSCPR01MB14966.jpnprd01.prod.outlook.com>
<efd05511-0b1f-4800-9eca-aadbf9bf5375@oss.nttdata.com>
<249358.1751643017@sss.pgh.pa.us>
<ac5d452d-7e9d-4643-b9e7-cb3423b04365@oss.nttdata.com>
<262595.1751649473@sss.pgh.pa.us>
On 2025/07/05 2:17, Tom Lane wrote:
> Fujii Masao <masao.fujii@oss.nttdata.com> writes:
>> On 2025/07/05 0:30, Tom Lane wrote:
>>> As I remarked in the other thread, I don't like inventing a different
>>> solution for each GUC. So if there are even two that need something
>>> done, I think Hayato-san's idea has merit.
>
>> This code seems to assume that the processing mode is switched to bootstrap before
>> GUC parameters are processed. But is that actually the case?
>
> Oh, good point. But there doesn't seem to be any ill effect from
> making BootstrapModeMain set BootstrapProcessing a bit earlier.
Maybe. But I noticed that your patch also moves the line "IgnoreSystemIndexes = true;"
earlier. Why did you make this change?
This could cause initdb to fail with a PANIC error when run with ignore_system_indexes=off,
like this:
$ initdb -D data -c ignore_system_indexes=off
...
FATAL: could not open relation with OID 2703
PANIC: cannot abort transaction 1, it was already committed
So perhaps "IgnoreSystemIndexes = true;" should be placed after GUCs are processed?
Or GUC ignore_system_indexes also should be treated in the same way
as transaction_timeout?
Regards,
--
Fujii Masao
NTT DATA Japan Corporation
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: masao.fujii@oss.nttdata.com, tgl@sss.pgh.pa.us, kuroda.hayato@fujitsu.com, zhihuifan1213@163.com, michael@paquier.xyz
Subject: Re: A assert failure when initdb with track_commit_timestamp=on
In-Reply-To: <75d59502-b571-4df8-9269-fd07cee52dd4@oss.nttdata.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox