From: Tom Lane <tgl@sss.pgh.pa.us>
To: Robert Haas <robertmhaas@gmail.com>
Cc: Alvaro Herrera <alvherre@2ndquadrant.com>
Cc: Magnus Hagander <magnus@hagander.net>
Cc: Bruce Momjian <bruce@momjian.us>
Cc: PostgreSQL-development <pgsql-hackers@postgresql.org>
Subject: Re: Rename max_parallel_degree?
Date: Tue, 26 Apr 2016 11:34:49 -0400
Message-ID: <8309.1461684889@sss.pgh.pa.us> (raw)
In-Reply-To: <CA+TgmoaDLa-pTjezHXb6S4HoNRM11TVGm_9GA9Ep+h4M_JWyLQ@mail.gmail.com>
References: <CA+TgmoZ5oGObjqV5CF3=7Haeui7auPCrp91R-9G7R4v0=6ajJQ@mail.gmail.com>
<20160426152217.GA548975@alvherre.pgsql>
<CA+TgmoaDLa-pTjezHXb6S4HoNRM11TVGm_9GA9Ep+h4M_JWyLQ@mail.gmail.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-hackers>
Robert Haas <robertmhaas@gmail.com> writes:
> On Tue, Apr 26, 2016 at 11:22 AM, Alvaro Herrera
> <alvherre@2ndquadrant.com> wrote:
>> I think the word "degree" is largely seen as a bad idea: it would become
>> a somewhat better idea only if we change how it works so that it matches
>> what other DBMSs do, but you oppose that. Hence my proposal to get rid
>> of that word in the UI.
> Well I agree with that up to a point, but I think ALTER TABLE foo SET
> (parallelism = 4) is not a model of clarity. "parallelism" or
> "parallel" is not obviously an integer quality. I guess we could
> s/parallel_degree/parallel_workers/g. I find that terminology less
> elegant than "parallel degree", but I can live with it.
Shouldn't it be "max_parallel_workers", at least in some contexts?
Otherwise, I'd read it as a promise that exactly that many workers
will be used.
regards, tom lane
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, robertmhaas@gmail.com, alvherre@2ndquadrant.com, magnus@hagander.net, bruce@momjian.us
Subject: Re: Rename max_parallel_degree?
In-Reply-To: <8309.1461684889@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox