public inbox for [email protected]
help / color / mirror / Atom feed[PATCH v9 4/4] WIP: check tuple size
2+ messages / 2 participants
[nested] [flat]
* [PATCH v9 4/4] WIP: check tuple size
@ 2020-12-01 23:20 Justin Pryzby <[email protected]>
0 siblings, 0 replies; 2+ messages in thread
From: Justin Pryzby @ 2020-12-01 23:20 UTC (permalink / raw)
Or maybe INSERT should flush buffer based only on the *number* of tuples, and
not their size ?
---
src/backend/executor/nodeModifyTable.c | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/src/backend/executor/nodeModifyTable.c b/src/backend/executor/nodeModifyTable.c
index 2059428e2a..04b0598183 100644
--- a/src/backend/executor/nodeModifyTable.c
+++ b/src/backend/executor/nodeModifyTable.c
@@ -703,7 +703,13 @@ ExecInsert(ModifyTableState *mtstate,
batchslot = MultiInsertInfoNextFreeSlot(mtstate->miinfo, resultRelInfo);
ExecCopySlot(batchslot, slot);
- MultiInsertInfoStore(mtstate->miinfo, resultRelInfo, batchslot, 0, 0); // XXX: tuplen/lineno
+ MultiInsertInfoStore(mtstate->miinfo, resultRelInfo, batchslot,
+ // sizeof(void*) * batchslot->tts_nvalid, /* tuple size - underestimate */
+ MemoryContextMemAllocated(batchslot->tts_mcxt, true), /* tuple size */
+ mtstate->ntuples); /* lineno */
+
+ elog(DEBUG2, "bufferedBytes %d; tuples %ld",
+ mtstate->miinfo->bufferedBytes, mtstate->ntuples);
if (MultiInsertInfoIsFull(mtstate->miinfo))
MultiInsertInfoFlush(mtstate->miinfo, resultRelInfo);
--
2.17.0
--3yNHWXBV/QO9xKNm--
^ permalink raw reply [nested|flat] 2+ messages in thread
* Re: make pg_createsubscriber option names more consistent
@ 2024-08-01 10:32 Peter Eisentraut <[email protected]>
0 siblings, 0 replies; 2+ messages in thread
From: Peter Eisentraut @ 2024-08-01 10:32 UTC (permalink / raw)
To: Hayato Kuroda (Fujitsu) <[email protected]>; +Cc: pgsql-hackers
On 31.07.24 11:15, Hayato Kuroda (Fujitsu) wrote:
> Dear Peter,
>
>> I propose to rename the pg_createsubscriber option --socket-directory to
>> --socketdir. This would make it match the equivalent option in
>> pg_upgrade. (It even has the same short option '-s'.)
>> pg_createsubscriber and pg_upgrade have a lot of common terminology and
>> a similar operating mode, so it would make sense to keep this consistent.
>
> +1. If so, should we say "default current dir." instead of "default current directory" in usage()
> because pg_upgrade says like that?
Committed with that change. Thanks.
^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2024-08-01 10:32 UTC | newest]
Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2020-12-01 23:20 [PATCH v9 4/4] WIP: check tuple size Justin Pryzby <[email protected]>
2024-08-01 10:32 Re: make pg_createsubscriber option names more consistent Peter Eisentraut <[email protected]>
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox