pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Michael Paquier <michael@paquier.xyz>
To: Julien Rouhaud <rjuju123@gmail.com>
Cc: Aleksander Alekseev <aleksander@timescale.com>
Cc: PostgreSQL Hackers <pgsql-hackers@lists.postgresql.org>
Cc: Nathan Bossart <nathandbossart@gmail.com>
Subject: Re: Allow file inclusion in pg_hba and pg_ident files
Date: Mon, 11 Jul 2022 10:16:44 +0900
Message-ID: <Yst5/P/EpUJdBGen@paquier.xyz> (raw)
In-Reply-To: <20220708065721.7q7x7glj3mc37b5c@jrouhaud>
References: <20220328083330.dmbbujtd3bhj6h7t@jrouhaud>
	<YkJfIAPcBd70bQq/@paquier.xyz>
	<20220329081454.tfa24qf5t5dyzjnt@jrouhaud>
	<20220518070938.pnucjfnp5yr6337l@jrouhaud>
	<YosvUhdMcckC+55Y@paquier.xyz>
	<20220523114308.qxnbjnxox23i5gsv@jrouhaud>
	<Yow4ZREPUyUp76hD@paquier.xyz>
	<20220526072657.7nptqy7ihxk4gkla@jrouhaud>
	<YpgNfzLBV6mdtRSg@paquier.xyz>
	<20220708065721.7q7x7glj3mc37b5c@jrouhaud>

On Fri, Jul 08, 2022 at 02:57:21PM +0800, Julien Rouhaud wrote:

My apologies for the late reply.

> I don't have an extensive knowledge of all the user facing error messages, but
> after a quick grep I see multiple usage of OID, PID, GIN and other defined
> acronyms.  I also see multiple occurrences of "only heap AM is supported",
> while AM isn't even a defined acronym.

A lot depends on the context of the code, it seems.

> It doesn't seem that my proposal would be inconsistent with existing messages
> and will help to reduce the message length, but if you prefer to keep the full
> name I'm fine with it.  Those should be very rare and specialized errors
> anyway.

So you mean to use "HBA file" instead of pg_hba.conf and
"authentication file" when it can be either one of an HBA file or a
mapping file?  That would be okay by me.  We would have a full cycle
to tune them depending on the feedback we'd get afterwards.

> While on the bikeshedding part, are you ok with the proposed keywords (include
> and include_dir), behaving exactly like for postgresql.conf, and to also add
> include_if_exists, so that we have the exact same possibilities with
> postgresql.conf, pg_hba.conf and pg_ident.conf?

Okay, agreed for consistency.  With include_dir being careful about
the ordering of the entries and ignoring anything else than a .conf
file (that's something you mentioned already upthread).
--
Michael

Attachments:

  [application/pgp-signature] signature.asc (832B, ../Yst5%2FP%2FEpUJdBGen@paquier.xyz/2-signature.asc)
  download

view thread (103+ messages)  latest in thread

Message-ID: <Yst5/P/EpUJdBGen@paquier.xyz>
Permalink:  ../Yst5%2FP%2FEpUJdBGen@paquier.xyz/
Also on:    postgresql.org/message-id/Yst5/P/EpUJdBGen@paquier.xyz

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: michael@paquier.xyz, rjuju123@gmail.com, aleksander@timescale.com, pgsql-hackers@lists.postgresql.org, nathandbossart@gmail.com
  Subject: Re: Allow file inclusion in pg_hba and pg_ident files
  In-Reply-To: <Yst5/P/EpUJdBGen@paquier.xyz>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox