From: Tom Lane <tgl@sss.pgh.pa.us>
To: Edward Amsden <amsden_linux@embarqmail.com>
Cc: pgsql-interfaces@postgreSQL.org
Subject: Re: pqlib large object error
Date: Tue, 10 Jun 2008 19:05:25 -0400
Message-ID: <26209.1213139125@sss.pgh.pa.us> (raw)
In-Reply-To: <1213134089.15557.22.camel@dad-desktop2>
References: <1213118594.9123.11.camel@dad-desktop2>
<21991.1213122593@sss.pgh.pa.us>
<1213130242.15557.3.camel@dad-desktop2>
<24396.1213130996@sss.pgh.pa.us>
<1213134089.15557.22.camel@dad-desktop2>
Edward Amsden <amsden_linux@embarqmail.com> writes:
> On Tue, 2008-06-10 at 16:49 -0400, Tom Lane wrote:
>> Hmph. The only thing I can think of is that that index is corrupt,
>> but it seems unlikely that it would be so in all databases. What
>> happens if you REINDEX pg_largeobject?
> The error has disappeared.
Hmm, so something did happen to your index.
> Now it can't write to the object. lo_open
> seems to be successful, but lo_write is failing with:
>> ERROR: invalid large-object descriptor: 0
You forgot to put the open-and-use-descriptor sequence inside a
BEGIN block.
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-interfaces@postgresql.org
Cc: tgl@sss.pgh.pa.us, amsden_linux@embarqmail.com
Subject: Re: pqlib large object error
In-Reply-To: <26209.1213139125@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox