From: Giles Lean <giles@nemeton.com.au>
To: Curtis Mortensen <shakiro2@yahoo.com>
Cc: pgsql-novice@postgresql.org
Subject: Re: pg_restore error
Date: Sat, 07 Sep 2002 12:34:09 +1000
Message-ID: <23718.1031366049@nemeton.com.au> (raw)
In-Reply-To: <shakiro2@yahoo.com> <CPECIDGAKENJOOCGOHGJCEOCCBAA.shakiro2@yahoo.com>
Hi Curtis,
> thanks for the advice. i now have a different error. :(
I suspected you would, but without knowing the commands you were using
decided guessing would only be confusing! Only the archive formats
from pg_dump are intended to be used with pg_restore. The default
output can be restored by psql:
$ pg_dump fubar > fubar.sql
$ createdb fubar2
CREATE DATABASE
$ psql fubar2 < fubar.sql
You are now connected as new user giles.
CREATE
$
$ pg_dump --format=c fubar > fubar.dump
$ createdb fubar2
CREATE DATABASE
$ pg_restore --dbname=fubar2 < fubar.dump
pg_restore: [archiver] WARNING:
Data restoration may fail because existing triggers cannot be disabled
(no superuser user name specified). This is only a problem when
restoring into a database with already existing triggers.
$
Regards,
Giles
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-novice@postgresql.org
Cc: giles@nemeton.com.au, shakiro2@yahoo.com
Subject: Re: pg_restore error
In-Reply-To: <23718.1031366049@nemeton.com.au>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox