agora inbox for pgsql-sql@postgresql.org
help / color / mirror / Atom feedFrom: jim_yates <pg@wg5jim.net>
To: pgsql-sql@postgresql.org
Subject: could not access status of transaction pg_multixact issue
Date: Wed, 8 Oct 2014 11:00:13 -0700 (PDT)
Message-ID: <1412791213607-5822248.post@n5.nabble.com> (raw)
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>
I have this issue for 1 table. Version is 9.3.5 upgraded from 9.2 with
pg_upgrade a few months ago.
This issues just started in the last couple of days.
acustream=# SELECT count(*) from phyorg_charges_to_invoice;
ERROR: could not access status of transaction 267035
DETAIL: Could not open file "pg_multixact/members/10AD6": No such file or
directory.
This error happens when I try and select or vacuum the table. Inserts still
work. I have a hot standby database and I can recover the data from there.
Is there any work around for this?
view thread (16+ messages) latest in thread
Message-ID: <1412791213607-5822248.post@n5.nabble.com>
Permalink: ../1412791213607-5822248.post@n5.nabble.com/
Also on: postgresql.org/message-id/1412791213607-5822248.post@n5.nabble.com
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-sql@postgresql.org
Cc: pg@wg5jim.net
Subject: Re: could not access status of transaction pg_multixact issue
In-Reply-To: <1412791213607-5822248.post@n5.nabble.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox