agora inbox for pgsql-sql@postgresql.org
help / color / mirror / Atom feedFrom: msn <pioneer.suri@gmail.com>
To: pgsql-sql@postgresql.org
Subject: org.postgresql.util.PSQLException: ERROR: index row requires more memory than default(8191)
Date: Mon, 18 Apr 2016 23:05:13 -0700 (MST)
Message-ID: <1461045913793-5899379.post@n5.nabble.com> (raw)
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>
I am trying to use PostgreSQL in our existing project to improve the
performance and make it fiendly with JSON. I have done some research on the
PostgerSQL and trying to integrate it into our application. But I am facing
some problem when I tried to insert the large json document into the table.
It is working with small set of json document but fails with the large data.
The following is the error dispalyed in the console when inserting the data.
org.postgresql.util.PSQLException: ERROR: index row requires 11936 bytes,
maximum size is 8191
at
org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2284)
at
org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:2003)
at
org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:200)
at org.postgresql.jdbc.PgStatement.execute(PgStatement.java:424)
at org.postgresql.jdbc.PgStatement.executeWithFlags(PgStatement.java:321)
at org.postgresql.jdbc.PgStatement.executeUpdate(PgStatement.java:297)
at com.practice.PracticeClass.main(PracticeClass.java:28)
org.postgresql.util.PSQLException: ERROR: index row requires 11936 bytes,
maximum size is 8191
In the above error, It is saying memory is not sufficient to create an
index. I am new to this Postgres. I am not creating any index when inserting
the json document. I am thinking it is internally creating an index for the
column.
Table creation: Create table sample(id serial, info jsonb);
Could any tell me how to resolve this error or how to configure to increase
the memory to insert large data.
--
View this message in context: http://postgresql.nabble.com/org-postgresql-util-PSQLException-ERROR-index-row-requires-more-memory-...
Sent from the PostgreSQL - sql mailing list archive at Nabble.com.
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
view thread (3+ messages) latest in thread
Message-ID: <1461045913793-5899379.post@n5.nabble.com>
Permalink: ../1461045913793-5899379.post@n5.nabble.com/
Also on: postgresql.org/message-id/1461045913793-5899379.post@n5.nabble.com
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-sql@postgresql.org
Cc: pioneer.suri@gmail.com
Subject: Re: org.postgresql.util.PSQLException: ERROR: index row requires more memory than default(8191)
In-Reply-To: <1461045913793-5899379.post@n5.nabble.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox