agora inbox for pgsql-sql@postgresql.org  
help / color / mirror / Atom feed
From: Tom Lane <tgl@sss.pgh.pa.us>
To: Stuart <sfbarbee@gmail.com>
Cc: pgsql-sql@postgresql.org <pgsql-sql@postgresql.org>
Subject: Re: ERROR: cache lookup failed for type
Date: Sun, 16 Aug 2015 23:16:35 -0400
Message-ID: <15241.1439781395@sss.pgh.pa.us> (raw)
In-Reply-To: <55D131B0.6010500@gmail.com>
References: <55D131B0.6010500@gmail.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>

Stuart <sfbarbee@gmail.com> writes:
> I have been using a particular function for years without issue but
> recently tried the Alpha releases of PostGreSQL.  I loaded the database
> into 9.5 Alpha1 release and did not have problems. After upgrading to
> Alpha2, I started getting this error on executing the function. I didn't
> reload the database this time as it should not be required.

>     ERROR:  cache lookup failed for type 1082
>     CONTEXT:  compilation of PL/pgSQL function "ds_stats" near line 1

That's odd.

> I dropped the function and can now not add it back to the database.

What happens when you try, exactly?

I assume the error was persistent across multiple sessions?  Have you
changed the schema (rowtype) of table documents_statistics lately?

Does reindexing pg_type make the error go away?  If so, what platform
and filesystem is this on?

			regards, tom lane


-- 
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql



view thread (9+ messages)  latest in thread

Message-ID: <15241.1439781395@sss.pgh.pa.us>
Permalink:  ../15241.1439781395@sss.pgh.pa.us/
Also on:    postgresql.org/message-id/15241.1439781395@sss.pgh.pa.us

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-sql@postgresql.org
  Cc: tgl@sss.pgh.pa.us, sfbarbee@gmail.com
  Subject: Re: ERROR: cache lookup failed for type
  In-Reply-To: <15241.1439781395@sss.pgh.pa.us>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox