agora inbox for pgsql-sql@postgresql.org  
help / color / mirror / Atom feed
How do I get rid of version 10 Postgresql completely ?
3+ messages / 2 participants
[nested] [flat]

* How do I get rid of version 10 Postgresql completely ?
@ 2019-09-25 15:03 Karen Goh <karenworld@yahoo.com>
  2019-09-25 15:52 ` Fw: How do I get rid of version 10 Postgresql completely ? Karen Goh <karenworld@yahoo.com>
  0 siblings, 1 reply; 3+ messages in thread

From: Karen Goh @ 2019-09-25 15:03 UTC (permalink / raw)
  To: pgsql-sql@lists.postgresql.org

Hello,

Whenever I start pgAdmin4 I will get this invalid literal for int() with base 10: 'None'.

And the other time I get this see version 10 still exist while playing with Ubuntu WSL.

I had uninstalled version 10 so I am not sure why there is still 
remnant lying around in my Windows 10 system.

Can someone kindly advise me how to get rid of PostgreSQL 10 completely.

Thanks in advance,
Karen





^ permalink  raw  reply  [nested|flat] 3+ messages in thread

* Fw: How do I get rid of version 10 Postgresql completely ?
  2019-09-25 15:03 How do I get rid of version 10 Postgresql completely ? Karen Goh <karenworld@yahoo.com>
@ 2019-09-25 15:52 ` Karen Goh <karenworld@yahoo.com>
  2019-09-25 16:05   ` Re: Fw: How do I get rid of version 10 Postgresql completely ? Rob Sargent <robjsargent@gmail.com>
  0 siblings, 1 reply; 3+ messages in thread

From: Karen Goh @ 2019-09-25 15:52 UTC (permalink / raw)
  To: pgsql-sql@lists.postgresql.org

 Hello,

Here's some more information to show the system still containing the uninstalled version 10:

root@DESKTOP-1KGGO27:~# sudo service postgresql start * Error: /usr/lib/postgresql/10/bin/pg_ctl /usr/lib/postgresql/10/bin/pg_ctl start -D /var/lib/postgresql/10/main -l /var/log/postgresql/postgresql-10-main.log -s -o -c config_file="/etc/postgresql/10/main/postgresql.conf" exited with status 1:
2019-09-25 23:49:04.217 +08 [116] LOG: could not bind IPv4 address "127.0.0.1": Permission denied
2019-09-25 23:49:04.217 +08 [116] HINT: Is another postmaster already running on port 5433? If not, wait a few seconds and retry.
2019-09-25 23:49:04.217 +08 [116] WARNING: could not create listen socket for "localhost"
2019-09-25 23:49:04.218 +08 [116] FATAL: could not create any TCP/IP sockets
2019-09-25 23:49:04.294 +08 [116] LOG: database system is shut down
pg_ctl: could not start server
Examine the log output.

Hope someone can tell me how to get rid of it completely.

Tks.    ----- Forwarded Message ----- From: Karen Goh <karenworld@yahoo.com>To: "pgsql-sql@lists.postgresql.org" <pgsql-sql@lists.postgresql.org>Sent: Wednesday, September 25, 2019, 11:03:29 PM GMT+8Subject: How do I get rid of version 10 Postgresql completely ?
 Hello,

Whenever I start pgAdmin4 I will get this invalid literal for int() with base 10: 'None'.

And the other time I get this see version 10 still exist while playing with Ubuntu WSL.

I had uninstalled version 10 so I am not sure why there is still 
remnant lying around in my Windows 10 system.

Can someone kindly advise me how to get rid of PostgreSQL 10 completely.

Thanks in advance,
Karen
  

^ permalink  raw  reply  [nested|flat] 3+ messages in thread

* Re: Fw: How do I get rid of version 10 Postgresql completely ?
  2019-09-25 15:03 How do I get rid of version 10 Postgresql completely ? Karen Goh <karenworld@yahoo.com>
  2019-09-25 15:52 ` Fw: How do I get rid of version 10 Postgresql completely ? Karen Goh <karenworld@yahoo.com>
@ 2019-09-25 16:05   ` Rob Sargent <robjsargent@gmail.com>
  0 siblings, 0 replies; 3+ messages in thread

From: Rob Sargent @ 2019-09-25 16:05 UTC (permalink / raw)
  To: pgsql-sql@lists.postgresql.org


On 9/25/19 9:52 AM, Karen Goh wrote:
> Hello,
>
> Here's some more information to show the system still containing the 
> uninstalled version 10:
>
> root@DESKTOP-1KGGO27:~# sudo service postgresql start * Error: 
> /usr/lib/postgresql/10/bin/pg_ctl /usr/lib/postgresql/10/bin/pg_ctl 
> start -D /var/lib/postgresql/10/main -l 
> /var/log/postgresql/postgresql-10-main.log -s -o -c 
> config_file="/etc/postgresql/10/main/postgresql.conf" exited with 
> status 1:
> 2019-09-25 23:49:04.217 +08 [116] LOG: could not bind IPv4 address 
> "127.0.0.1": Permission denied
> 2019-09-25 23:49:04.217 +08 [116] HINT: Is another postmaster already 
> running on port 5433? If not, wait a few seconds and retry.
> 2019-09-25 23:49:04.217 +08 [116] WARNING: could not create listen 
> socket for "localhost"
> 2019-09-25 23:49:04.218 +08 [116] FATAL: could not create any TCP/IP 
> sockets
> 2019-09-25 23:49:04.294 +08 [116] LOG: database system is shut down
> pg_ctl: could not start server
> Examine the log output.
>
> Hope someone can tell me how to get rid of it completely.
>
> Tks.
>
Karen,

Those look like linux commands?  Are you removing postgres from 
"DESKTOP-1KGG027"?  Try

    ps elf | grep postgres

to see the running postgres processes.

    sudo service postgresql stop

should stop the running instance

    cat /etc/os-release

to see what os is running, if you're unsure.  Do you know how postgres 
was installed? (Maybe apt or yum or similar?)

^ permalink  raw  reply  [nested|flat] 3+ messages in thread


end of thread, other threads:[~2019-09-25 16:05 UTC | newest]

Thread overview: 3+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2019-09-25 15:03 How do I get rid of version 10 Postgresql completely ? Karen Goh <karenworld@yahoo.com>
2019-09-25 15:52 ` Karen Goh <karenworld@yahoo.com>
2019-09-25 16:05   ` Rob Sargent <robjsargent@gmail.com>

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox