pg.ddx.io pgsql-hackers@postgresql.org mailing list archive
help / color / mirror / Atom feedMinor comment fix for pg_config_manual.h
8+ messages / 4 participants
[nested] [flat]
Commits from this thread:
2018-12-28 0a5a493f04 6a19384e74 Improve description of DEFAULT_XLOG_SEG_SIZE in pg_config.h
* Minor comment fix for pg_config_manual.h
@ 2018-12-24 04:05 Ian Barwick <ian.barwick@2ndquadrant.com>
0 siblings, 1 reply; 8+ messages in thread
From: Ian Barwick @ 2018-12-24 04:05 UTC (permalink / raw)
To: pgsql-hackers
Hi
Attached is mainly to fix a comment in $subject which has a typo in the referenced initdb
option ("--walsegsize", should be "--wal-segsize"), and while I'm there also adds a
couple of "the" for readability.
Regards
Ian Barwick
--
Ian Barwick http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services
Attachments:
pg_config_manual-v1.patch (text/x-patch, 673B) download
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
new file mode 100644
index cc5eedf..cf1cfb4
*** a/src/include/pg_config_manual.h
--- b/src/include/pg_config_manual.h
***************
*** 14,21 ****
*/
/*
! * This is default value for wal_segment_size to be used at initdb when run
! * without --walsegsize option. Must be a valid segment size.
*/
#define DEFAULT_XLOG_SEG_SIZE (16*1024*1024)
--- 14,21 ----
*/
/*
! * This is the default value for wal_segment_size to be used at initdb when run
! * without the --wal-segsize option. Must be a valid segment size.
*/
#define DEFAULT_XLOG_SEG_SIZE (16*1024*1024)
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-24 08:57 Michael Paquier <michael@paquier.xyz>
parent: Ian Barwick <ian.barwick@2ndquadrant.com>
0 siblings, 1 reply; 8+ messages in thread
From: Michael Paquier @ 2018-12-24 08:57 UTC (permalink / raw)
To: Ian Barwick <ian.barwick@2ndquadrant.com>; +Cc: pgsql-hackers
On Mon, Dec 24, 2018 at 01:05:25PM +0900, Ian Barwick wrote:
> Attached is mainly to fix a comment in $subject which has a typo in
> the referenced initdb option ("--walsegsize", should be
> "--wal-segsize"), and while I'm there also adds a couple of "the"
> for readability.
All that (the error as well as the extra "the" for clarity in this
sentence) seems right to me. Any opinions from others?
--
Michael
Attachments:
signature.asc (application/pgp-signature, 832B) download
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-25 15:22 Tom Lane <tgl@sss.pgh.pa.us>
parent: Michael Paquier <michael@paquier.xyz>
0 siblings, 1 reply; 8+ messages in thread
From: Tom Lane @ 2018-12-25 15:22 UTC (permalink / raw)
To: Michael Paquier <michael@paquier.xyz>; +Cc: Ian Barwick <ian.barwick@2ndquadrant.com>; pgsql-hackers
Michael Paquier <michael@paquier.xyz> writes:
> On Mon, Dec 24, 2018 at 01:05:25PM +0900, Ian Barwick wrote:
>> Attached is mainly to fix a comment in $subject which has a typo in
>> the referenced initdb option ("--walsegsize", should be
>> "--wal-segsize"), and while I'm there also adds a couple of "the"
>> for readability.
> All that (the error as well as the extra "the" for clarity in this
> sentence) seems right to me. Any opinions from others?
The text still seems a bit awkward. Maybe "... to be used when initdb
is run without the ..."
regards, tom lane
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-26 00:36 Michael Paquier <michael@paquier.xyz>
parent: Tom Lane <tgl@sss.pgh.pa.us>
0 siblings, 1 reply; 8+ messages in thread
From: Michael Paquier @ 2018-12-26 00:36 UTC (permalink / raw)
To: Tom Lane <tgl@sss.pgh.pa.us>; +Cc: Ian Barwick <ian.barwick@2ndquadrant.com>; pgsql-hackers
On Tue, Dec 25, 2018 at 10:22:30AM -0500, Tom Lane wrote:
> The text still seems a bit awkward. Maybe "... to be used when initdb
> is run without the ..."
like the attached perhaps? At the same time I am thinking about
reformulating the second sentence as well..
--
Michael
Attachments:
pg_config_manual-v2.patch (text/x-diff, 561B) download
diff --git a/src/include/pg_config_manual.h b/src/include/pg_config_manual.h
index cc5eedfc41..02395af797 100644
--- a/src/include/pg_config_manual.h
+++ b/src/include/pg_config_manual.h
@@ -14,8 +14,8 @@
*/
/*
- * This is default value for wal_segment_size to be used at initdb when run
- * without --walsegsize option. Must be a valid segment size.
+ * This is the default value for wal_segment_size to be used when initdb is run
+ * without the --wal-segsize option. It must be a valid segment size.
*/
#define DEFAULT_XLOG_SEG_SIZE (16*1024*1024)
signature.asc (application/pgp-signature, 832B) download
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-28 01:41 Michael Paquier <michael@paquier.xyz>
parent: Michael Paquier <michael@paquier.xyz>
0 siblings, 1 reply; 8+ messages in thread
From: Michael Paquier @ 2018-12-28 01:41 UTC (permalink / raw)
To: Tom Lane <tgl@sss.pgh.pa.us>; +Cc: Ian Barwick <ian.barwick@2ndquadrant.com>; pgsql-hackers
On Wed, Dec 26, 2018 at 09:36:57AM +0900, Michael Paquier wrote:
> like the attached perhaps? At the same time I am thinking about
> reformulating the second sentence as well..
>
> /*
> - * This is default value for wal_segment_size to be used at initdb when run
> - * without --walsegsize option. Must be a valid segment size.
> + * This is the default value for wal_segment_size to be used when initdb is run
> + * without the --wal-segsize option. It must be a valid segment size.
> */
> #define DEFAULT_XLOG_SEG_SIZE (16*1024*1024)
So, any objections with this change? If somebody has a better
wording, please feel free to chime in.
--
Michael
Attachments:
signature.asc (application/pgp-signature, 832B) download
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-28 03:37 Alvaro Herrera <alvherre@2ndquadrant.com>
parent: Michael Paquier <michael@paquier.xyz>
0 siblings, 1 reply; 8+ messages in thread
From: Alvaro Herrera @ 2018-12-28 03:37 UTC (permalink / raw)
To: Michael Paquier <michael@paquier.xyz>; +Cc: Tom Lane <tgl@sss.pgh.pa.us>; Ian Barwick <ian.barwick@2ndquadrant.com>; pgsql-hackers
On 2018-Dec-28, Michael Paquier wrote:
> On Wed, Dec 26, 2018 at 09:36:57AM +0900, Michael Paquier wrote:
> > like the attached perhaps? At the same time I am thinking about
> > reformulating the second sentence as well..
> >
> > /*
> > - * This is default value for wal_segment_size to be used at initdb when run
> > - * without --walsegsize option. Must be a valid segment size.
> > + * This is the default value for wal_segment_size to be used when initdb is run
> > + * without the --wal-segsize option. It must be a valid segment size.
> > */
> > #define DEFAULT_XLOG_SEG_SIZE (16*1024*1024)
>
> So, any objections with this change? If somebody has a better
> wording, please feel free to chime in.
Looks good to me.
--
Álvaro Herrera https://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-28 23:27 Michael Paquier <michael@paquier.xyz>
parent: Alvaro Herrera <alvherre@2ndquadrant.com>
0 siblings, 1 reply; 8+ messages in thread
From: Michael Paquier @ 2018-12-28 23:27 UTC (permalink / raw)
To: Alvaro Herrera <alvherre@2ndquadrant.com>; +Cc: Tom Lane <tgl@sss.pgh.pa.us>; Ian Barwick <ian.barwick@2ndquadrant.com>; pgsql-hackers
On Fri, Dec 28, 2018 at 12:37:41AM -0300, Alvaro Herrera wrote:
> Looks good to me.
Thanks for the lookup. I have committed and back-patched to v11 for
consistency.
--
Michael
Attachments:
signature.asc (application/pgp-signature, 832B) download
^ permalink raw reply [nested|flat] 8+ messages in thread
* Re: Minor comment fix for pg_config_manual.h
@ 2018-12-31 00:50 Ian Barwick <ian.barwick@2ndquadrant.com>
parent: Michael Paquier <michael@paquier.xyz>
0 siblings, 0 replies; 8+ messages in thread
From: Ian Barwick @ 2018-12-31 00:50 UTC (permalink / raw)
To: Michael Paquier <michael@paquier.xyz>; +Cc: Alvaro Herrera <alvherre@2ndquadrant.com>; Tom Lane <tgl@sss.pgh.pa.us>; pgsql-hackers
On 12/29/18 8:27 AM, Michael Paquier wrote:
> On Fri, Dec 28, 2018 at 12:37:41AM -0300, Alvaro Herrera wrote:
>> Looks good to me.
>
> Thanks for the lookup. I have committed and back-patched to v11 for
> consistency.
Thanks!
Regards
Ian Barwick
--
Ian Barwick http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services
^ permalink raw reply [nested|flat] 8+ messages in thread
end of thread, other threads:[~2018-12-31 00:50 UTC | newest]
Thread overview: 8+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2018-12-24 04:05 Minor comment fix for pg_config_manual.h Ian Barwick <ian.barwick@2ndquadrant.com>
2018-12-24 08:57 ` Michael Paquier <michael@paquier.xyz>
2018-12-25 15:22 ` Tom Lane <tgl@sss.pgh.pa.us>
2018-12-26 00:36 ` Michael Paquier <michael@paquier.xyz>
2018-12-28 01:41 ` Michael Paquier <michael@paquier.xyz>
2018-12-28 03:37 ` Alvaro Herrera <alvherre@2ndquadrant.com>
2018-12-28 23:27 ` Michael Paquier <michael@paquier.xyz>
2018-12-31 00:50 ` Ian Barwick <ian.barwick@2ndquadrant.com>
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox