pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Tomas Vondra <tomas.vondra@2ndquadrant.com>
To: Robert Haas <robertmhaas@gmail.com>
Cc: Julien Rouhaud <rjuju123@gmail.com>
Cc: Peter Eisentraut <peter.eisentraut@2ndquadrant.com>
Cc: pgsql-hackers <pgsql-hackers@postgresql.org>
Subject: Re: suggest to rename enable_incrementalsort
Date: Mon, 22 Jun 2020 16:31:14 +0200
Message-ID: <20200622143114.suqf2korqpydbxxf@development> (raw)
In-Reply-To: <CA+TgmoazhPwebpOwNbHt1vJoos1eLYhJVQPka+pptSLgS685aA@mail.gmail.com>
References: <df652910-e985-9547-152c-9d4357dc3979@2ndquadrant.com>
	<CAOBaU_bsOKEXgF_ik3bjAfV7HQAM+2MTbAwtKujqiu1YueeUiQ@mail.gmail.com>
	<20200621112159.qtgedtrqw2c47pm4@development>
	<CA+TgmoazhPwebpOwNbHt1vJoos1eLYhJVQPka+pptSLgS685aA@mail.gmail.com>

On Mon, Jun 22, 2020 at 10:16:54AM -0400, Robert Haas wrote:
>On Sun, Jun 21, 2020 at 7:22 AM Tomas Vondra
><tomas.vondra@2ndquadrant.com> wrote:
>> The reason why I kept the single-word variant is consistency with other
>> GUCs that affect planning, like enable_indexscan, enable_hashjoin and
>> many others.
>
>Right, so that makes sense, but from a larger point of view, how much
>sense does it actually make? I mean, I get the argument from tradition
>and from internal naming consistency, but from a user perspective, why
>does it makes sense for there to be underscores between some of the
>words and not others? I think it just feels random, like someone is
>charging us $1 per underscore so we're economizing.
>

Sure. I'm not particularly attached to the current GUC, I've only tried
to explain that the naming was not entirely random. I agree having an
extra _ in the name would make it more readable.


>So I'm +1 for changing this, and I'd definitely be +1 for renaming the
>others if they weren't released already, and at least +0.5 for it
>anyhow. It's bad enough that our source code has names_like_this and
>NamesLikeThis and namesLikeThis; when we also start adding
>names_likethis and NamesLike_this and maybe NaMeS___LiKeTh_is, I kind
>of lose my mind. And avoiding that sort of thing in user-facing stuff
>seems even more important.
>

OK, challenge accepted. $100 to the first person who commits a patch
with a variable NaMeS___LiKeTh_is.


regards

-- 
Tomas Vondra                  http://www.2ndQuadrant.com
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services





view thread (14+ messages)  latest in thread

Message-ID: <20200622143114.suqf2korqpydbxxf@development>
Permalink:  ../20200622143114.suqf2korqpydbxxf@development/
Also on:    postgresql.org/message-id/20200622143114.suqf2korqpydbxxf@development

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: tomas.vondra@2ndquadrant.com, robertmhaas@gmail.com, rjuju123@gmail.com, peter.eisentraut@2ndquadrant.com
  Subject: Re: suggest to rename enable_incrementalsort
  In-Reply-To: <20200622143114.suqf2korqpydbxxf@development>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox