pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Alvaro Herrera <alvherre@alvh.no-ip.org>
To: Noah Misch <noah@leadboat.com>
Cc: Tom Lane <tgl@sss.pgh.pa.us>
Cc: Kyotaro Horiguchi <horikyota.ntt@gmail.com>
Cc: iwata.aya@fujitsu.com
Cc: tsunakawa.takay@fujitsu.com
Cc: k.jamison@fujitsu.com
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: libpq debug log
Date: Sat, 5 Jun 2021 11:02:49 -0400
Message-ID: <202106051502.l252ugdz7cg6@alvherre.pgsql> (raw)
In-Reply-To: <20210605060555.GA216695@rfd.leadboat.com>

On 2021-Jun-04, Noah Misch wrote:

> On Fri, Apr 09, 2021 at 05:16:11PM -0400, Alvaro Herrera wrote:
> > Pushed now.
> 
> This added a PQtraceSetFlags() function.  We have a dozen PQset*() functions,
> but this and PQresultSetInstanceData() are the only PQSomethingSet()
> functions.  Is it okay if I rename it to PQsetTraceFlags()?  I think that
> would be more idiomatic for libpq.

Hmm, there is an obvious parallel between PQtrace() and
PQtraceSetFlags() which is lost with your proposed rename.  I'm not
wedded to the name though, so I'm just -0.1 on the rename.  If you feel
strongly about it, I won't oppose it.

-- 
Álvaro Herrera       Valdivia, Chile
"La espina, desde que nace, ya pincha" (Proverbio africano)





view thread (234+ messages)  latest in thread

Message-ID: <202106051502.l252ugdz7cg6@alvherre.pgsql>
Permalink:  ../202106051502.l252ugdz7cg6@alvherre.pgsql/
Also on:    postgresql.org/message-id/202106051502.l252ugdz7cg6@alvherre.pgsql

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: alvherre@alvh.no-ip.org, noah@leadboat.com, tgl@sss.pgh.pa.us, horikyota.ntt@gmail.com, iwata.aya@fujitsu.com, tsunakawa.takay@fujitsu.com, k.jamison@fujitsu.com, pgsql-hackers@lists.postgresql.org
  Subject: Re: libpq debug log
  In-Reply-To: <202106051502.l252ugdz7cg6@alvherre.pgsql>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox