public inbox for [email protected]help / color / mirror / Atom feed
[PATCH v6 02/10] doc: pg_stat_progress_basebackup 5+ messages / 4 participants [nested] [flat]
* [PATCH v6 02/10] doc: pg_stat_progress_basebackup @ 2020-03-30 02:22 Justin Pryzby <[email protected]> 0 siblings, 0 replies; 5+ messages in thread From: Justin Pryzby @ 2020-03-30 02:22 UTC (permalink / raw) commit e65497df8f85ab9b9084c928ff69f384ea729b24 Author: Fujii Masao <[email protected]> --- doc/src/sgml/monitoring.sgml | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgml index 304c49f07b..ea8780327f 100644 --- a/doc/src/sgml/monitoring.sgml +++ b/doc/src/sgml/monitoring.sgml @@ -6069,8 +6069,8 @@ SELECT pg_stat_get_backend_pid(s.backendid) AS pid, <entry><literal>waiting for checkpoint to finish</literal></entry> <entry> The WAL sender process is currently performing - <function>pg_start_backup</function> to set up for - taking a base backup, and waiting for backup start + <function>pg_start_backup</function> to prepare to + take a base backup, and waiting for the start-of-backup checkpoint to finish. </entry> </row> -- 2.17.0 --C+ts3FVlLX8+P6JN Content-Type: text/x-diff; charset=us-ascii Content-Disposition: attachment; filename="v6-0003-Fix-docs-time-of-the.patch" ^ permalink raw reply [nested|flat] 5+ messages in thread
* Re: convert libpq uri-regress tests to tap test @ 2022-02-23 20:39 Andrew Dunstan <[email protected]> 0 siblings, 1 reply; 5+ messages in thread From: Andrew Dunstan @ 2022-02-23 20:39 UTC (permalink / raw) To: Andres Freund <[email protected]>; pgsql-hackers On 2/23/22 15:30, Andres Freund wrote: > Hi, > > When verifying that the meson port actually runs all perl based tests I came > across src/interfaces/libpq/test/regress.pl. Instead of running tests yet > another way, it seems better to convert it to a tap test. > > I hope others agree? yes > > Where would we want that test to live? Right now we have the slightly odd > convention that some tap tests live in src/test/{misc,modules,...}. But > e.g. frontend binary ones are below src/bin/. > > For now I've left it in src/interfaces/libpq/test, with the test in > t/001_uri.pl. But we should at least get rid of the test/... > > Perhaps we should just rename src/test/modules/libpq_pipeline to > src/test/modules/libpq and move uri-regress in there as well? WFM cheers andrew -- Andrew Dunstan EDB: https://www.enterprisedb.com ^ permalink raw reply [nested|flat] 5+ messages in thread
* Re: convert libpq uri-regress tests to tap test @ 2022-02-23 20:57 Tom Lane <[email protected]> parent: Andrew Dunstan <[email protected]> 0 siblings, 1 reply; 5+ messages in thread From: Tom Lane @ 2022-02-23 20:57 UTC (permalink / raw) To: Andrew Dunstan <[email protected]>; +Cc: Andres Freund <[email protected]>; pgsql-hackers Andrew Dunstan <[email protected]> writes: > On 2/23/22 15:30, Andres Freund wrote: >> Perhaps we should just rename src/test/modules/libpq_pipeline to >> src/test/modules/libpq and move uri-regress in there as well? > WFM +1 regards, tom lane ^ permalink raw reply [nested|flat] 5+ messages in thread
* Re: convert libpq uri-regress tests to tap test @ 2022-02-23 21:16 Andres Freund <[email protected]> parent: Tom Lane <[email protected]> 0 siblings, 1 reply; 5+ messages in thread From: Andres Freund @ 2022-02-23 21:16 UTC (permalink / raw) To: Tom Lane <[email protected]>; +Cc: Andrew Dunstan <[email protected]>; pgsql-hackers Hi, On 2022-02-23 15:57:08 -0500, Tom Lane wrote: > Andrew Dunstan <[email protected]> writes: > > On 2/23/22 15:30, Andres Freund wrote: > >> Perhaps we should just rename src/test/modules/libpq_pipeline to > >> src/test/modules/libpq and move uri-regress in there as well? > > > WFM > > +1 Cool. One question on making that happen: Right now the makefiles building C stuff in src/test/modules all have the contrib-style stanza to build via pgxs. But afaics pgxs doesn't support building multiple programs. Which src/test/modules/libpq would need to. Aaics there's currently no way to have Mkvcbuild.pm build multiple programs in one dir via its makefile parsing stuff? Andrew, any suggestions for not needing to spell this out in both the makefile and Mkvcbuild.pm? Separately: I don't really understand why we do the whole if USE_PGXS dance in src/test/modules? - Andres ^ permalink raw reply [nested|flat] 5+ messages in thread
* Re: convert libpq uri-regress tests to tap test @ 2022-02-23 21:57 Andrew Dunstan <[email protected]> parent: Andres Freund <[email protected]> 0 siblings, 0 replies; 5+ messages in thread From: Andrew Dunstan @ 2022-02-23 21:57 UTC (permalink / raw) To: Andres Freund <[email protected]>; Tom Lane <[email protected]>; +Cc: pgsql-hackers On 2/23/22 16:16, Andres Freund wrote: > Hi, > > On 2022-02-23 15:57:08 -0500, Tom Lane wrote: >> Andrew Dunstan <[email protected]> writes: >>> On 2/23/22 15:30, Andres Freund wrote: >>>> Perhaps we should just rename src/test/modules/libpq_pipeline to >>>> src/test/modules/libpq and move uri-regress in there as well? >>> WFM >> +1 > Cool. > > > One question on making that happen: Right now the makefiles building C stuff > in src/test/modules all have the contrib-style stanza to build via pgxs. But > afaics pgxs doesn't support building multiple programs. Which > src/test/modules/libpq would need to. That's my understanding also. > > Aaics there's currently no way to have Mkvcbuild.pm build multiple programs in > one dir via its makefile parsing stuff? Andrew, any suggestions for not > needing to spell this out in both the makefile and Mkvcbuild.pm? Well, it should be a SMOC. If you can solve the first problem I'm sure I can come up with a solution for Mkvcbuild.pm. But until we see the shape of the pgxs changes, planning for Mkcvbuild.pm changes seems remature. > > > Separately: I don't really understand why we do the whole if USE_PGXS dance in > src/test/modules? > ENOCLUE cheers andrew -- Andrew Dunstan EDB: https://www.enterprisedb.com ^ permalink raw reply [nested|flat] 5+ messages in thread
end of thread, other threads:[~2022-02-23 21:57 UTC | newest] Thread overview: 5+ messages (download: mbox mbox.gz follow: Atom feed) -- links below jump to the message on this page -- 2020-03-30 02:22 [PATCH v6 02/10] doc: pg_stat_progress_basebackup Justin Pryzby <[email protected]> 2022-02-23 20:39 Re: convert libpq uri-regress tests to tap test Andrew Dunstan <[email protected]> 2022-02-23 20:57 ` Re: convert libpq uri-regress tests to tap test Tom Lane <[email protected]> 2022-02-23 21:16 ` Re: convert libpq uri-regress tests to tap test Andres Freund <[email protected]> 2022-02-23 21:57 ` Re: convert libpq uri-regress tests to tap test Andrew Dunstan <[email protected]>
This inbox is served by agora; see mirroring instructions for how to clone and mirror all data and code used for this inbox