pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Nathan Bossart <nathandbossart@gmail.com>
To: Thibaud W. <thibaud.walkowiak@dalibo.com>
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: Proposal: adding a better description in psql command about large objects
Date: Fri, 3 Jun 2022 07:39:21 -0700
Message-ID: <20220603143921.GA2624579@nathanxps13> (raw)
In-Reply-To: <2e872233-1642-439c-dd94-56fc25d398cb@dalibo.com>
References: <43f0439c-df3e-a045-ac99-af33523cc2d4@dalibo.com>
	<20220602214625.GA2494933@nathanxps13>
	<2e872233-1642-439c-dd94-56fc25d398cb@dalibo.com>

On Fri, Jun 03, 2022 at 10:12:30AM +0200, Thibaud W. wrote:
> In fact the original tabs were missing in the first file.
> In version v2, it seems interesting to keep calls to the fprintf function
> for translation. I attached a new file.

Yes, it looks like the precedent is to have an fprintf() per command.  I
still think the indentation needs some adjustment for readability.  In the
attached, I've lined up all the large object commands.  This is offset from
most other commands, but IMO this is far easier to read, and something
similar was done for the operator class/family commands.  Thoughts?

-- 
Nathan Bossart
Amazon Web Services: https://aws.amazon.com

Attachments:

v4-0001-Add-descriptions-for-psql-s-large-object-backslas.patch (text/x-diff, 1.4K) download From 046e450e6d578fe365ef6c561a477d70d09f3076 Mon Sep 17 00:00:00 2001 From: Nathan Bossart <nathandbossart@gmail.com> Date: Thu, 2 Jun 2022 14:35:31 -0700 Subject: [PATCH v4 1/1] Add descriptions for psql's large object backslash commands. These should be mostly self-explanatory, but they are the only backslash commands lacking individual short descriptions. Author: Thibaud W. Reviewed by: Nathan Bossart Description: https://postgr.es/m/43f0439c-df3e-a045-ac99-af33523cc2d4%40dalibo.com --- src/bin/psql/help.c | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/src/bin/psql/help.c b/src/bin/psql/help.c index 49eb116f33..33902d496a 100644 --- a/src/bin/psql/help.c +++ b/src/bin/psql/help.c @@ -321,10 +321,10 @@ slashUsage(unsigned short int pager) fprintf(output, "\n"); fprintf(output, _("Large Objects\n")); - fprintf(output, _(" \\lo_export LOBOID FILE\n" - " \\lo_import FILE [COMMENT]\n" - " \\lo_list[+]\n" - " \\lo_unlink LOBOID large object operations\n")); + fprintf(output, _(" \\lo_export LOBOID FILE export large object to file\n")); + fprintf(output, _(" \\lo_import FILE [COMMENT] import large object from file\n")); + fprintf(output, _(" \\lo_list[+] list large objects\n")); + fprintf(output, _(" \\lo_unlink LOBOID delete a large object\n")); ClosePager(output); } -- 2.25.1

view thread (10+ messages)  latest in thread

Message-ID: <20220603143921.GA2624579@nathanxps13>
Permalink:  ../20220603143921.GA2624579@nathanxps13/
Also on:    postgresql.org/message-id/20220603143921.GA2624579@nathanxps13

 ·  · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: nathandbossart@gmail.com, thibaud.walkowiak@dalibo.com, pgsql-hackers@lists.postgresql.org
  Subject: Re: Proposal: adding a better description in psql command about large objects
  In-Reply-To: <20220603143921.GA2624579@nathanxps13>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox