From: Tom Lane <tgl@sss.pgh.pa.us>
To: Alexey Bashtanov <bashtanov@imap.cc>
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: Less-silly selectivity for JSONB matching operators
Date: Tue, 31 Mar 2020 12:29:25 -0400
Message-ID: <9662.1585672165@sss.pgh.pa.us> (raw)
In-Reply-To: <7e87d82d-326a-a8df-ee4f-ec708c701dce@imap.cc>
References: <12237.1582833074@sss.pgh.pa.us>
<14469.1582927774@sss.pgh.pa.us>
<8fcbdcc5-cbed-f96f-7ed4-f34d1bd1a205@imap.cc>
<9233.1585671632@sss.pgh.pa.us>
<7e87d82d-326a-a8df-ee4f-ec708c701dce@imap.cc>
Alexey Bashtanov <bashtanov@imap.cc> writes:
>> So that leaves us with needing
>> to find a better name for this new one. Any ideas?
> I'm thinking of something wide like
> opersel, operjoinsel, DEFAULT_OPER_SEL
> or maybe even
> genericsel, genericjoinsel, DEFAULT_GENERIC_SEL
Seems a little *too* generic :-(
I was wondering about DEFAULT_MATCHING_SEL. The difference in purpose
from DEFAULT_MATCH_SEL wouldn't be too obvious, but then it probably
wouldn't be anyway.
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, bashtanov@imap.cc, pgsql-hackers@lists.postgresql.org
Subject: Re: Less-silly selectivity for JSONB matching operators
In-Reply-To: <9662.1585672165@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox