agora inbox for pgsql-sql@postgresql.org  
help / color / mirror / Atom feed
From: Alvaro Herrera <alvherre@2ndquadrant.com>
To: jim_yates <pg@wg5jim.net>
Cc: pgsql-sql@postgresql.org
Subject: Re: could not access status of transaction pg_multixact issue
Date: Wed, 8 Oct 2014 15:55:38 -0300
Message-ID: <20141008185538.GY7043@eldon.alvh.no-ip.org> (raw)
In-Reply-To: <1412791213607-5822248.post@n5.nabble.com>
References: <1412791213607-5822248.post@n5.nabble.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>

jim_yates wrote:
> I have this issue for 1 table.   Version is 9.3.5  upgraded from 9.2 with
> pg_upgrade a few months ago.
> 
> This issues just started in the last couple of days.
> 
> acustream=# SELECT count(*) from phyorg_charges_to_invoice;
> ERROR:  could not access status of transaction 267035
> DETAIL:  Could not open file "pg_multixact/members/10AD6": No such file or
> directory.
> 
> This error happens when I try and select or vacuum the table.  Inserts still
> work.  I have a hot standby database and I can recover the data from there.  
> Is there any work around for this?  

Please see this thread:
http://www.postgresql.org/message-id/loom.20140930T022539-927@post.gmane.org

My bet is you upgraded to a 9.3 version older than 9.3.5; this means
your relminmxid/datminmxid are set to 1 and need to be updated.

-- 
Álvaro Herrera                http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services


-- 
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql



view thread (16+ messages)  latest in thread

Message-ID: <20141008185538.GY7043@eldon.alvh.no-ip.org>
Permalink:  ../20141008185538.GY7043@eldon.alvh.no-ip.org/
Also on:    postgresql.org/message-id/20141008185538.GY7043@eldon.alvh.no-ip.org

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-sql@postgresql.org
  Cc: alvherre@2ndquadrant.com, pg@wg5jim.net
  Subject: Re: could not access status of transaction pg_multixact issue
  In-Reply-To: <20141008185538.GY7043@eldon.alvh.no-ip.org>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox