agora inbox for pgsql-sql@postgresql.org  
help / color / mirror / Atom feed
From: Stuart <sfbarbee@gmail.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
To: adrian.klaver@aklaver.com
Cc: pgsql-sql@postgresql.org <pgsql-sql@postgresql.org>
Subject: Re: ERROR: cache lookup failed for type
Date: Mon, 17 Aug 2015 07:52:02 +0400
Message-ID: <55D15A62.70406@gmail.com> (raw)
In-Reply-To: <15241.1439781395@sss.pgh.pa.us>
References: <55D131B0.6010500@gmail.com>
	<15241.1439781395@sss.pgh.pa.us>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>

Adrian, Tom,

   I reloaded the database and the problem doesn't happen anymore.
Thanks for the suggestion.

Tom - to answer your questions,

On 08/17/2015 07:16 AM, Tom Lane wrote:
>> I dropped the function and can now not add it back to the database.
> 
> What happens when you try, exactly?

The same error occurred

> I assume the error was persistent across multiple sessions?  Have you
> changed the schema (rowtype) of table documents_statistics lately?

No there were no changes to the table schema.  All dbase objects were
loaded via

pg_dumpall > file.sql

upgrade postgres

psql template1 -f file.sql

Yes the problem was persistent across multiple sessions

> Does reindexing pg_type make the error go away?  If so, what platform
> and filesystem is this on?

No, I didn't try reindexing pg_type

The filesystem is XFS


Thanks,

Stuart


-- 
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql



view thread (9+ messages)  latest in thread

Message-ID: <55D15A62.70406@gmail.com>
Permalink:  ../55D15A62.70406@gmail.com/
Also on:    postgresql.org/message-id/55D15A62.70406@gmail.com

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-sql@postgresql.org
  Cc: sfbarbee@gmail.com, tgl@sss.pgh.pa.us, adrian.klaver@aklaver.com
  Subject: Re: ERROR: cache lookup failed for type
  In-Reply-To: <55D15A62.70406@gmail.com>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox