From: Tom Lane <tgl@sss.pgh.pa.us>
To: Álvaro Herrera <alvherre@kurilemu.de>
Cc: d.kovalenko@postgrespro.ru
Cc: pgsql-bugs@lists.postgresql.org
Subject: Re: BUG #18960: Mistake in test test_simple_pipeline (libpq_pipeline.c)
Date: Wed, 03 Sep 2025 10:48:17 -0400
Message-ID: <803146.1756910897@sss.pgh.pa.us> (raw)
In-Reply-To: <202509031228.wuh3frddxcvl@alvherre.pgsql>
References: <202509031228.wuh3frddxcvl@alvherre.pgsql>
=?utf-8?Q?=C3=81lvaro?= Herrera <alvherre@kurilemu.de> writes:
> On 2025-Jun-21, Tom Lane wrote:
>> Here's a shot at improving matters. I also made an effort
>> at cleaning up memory leaks in libpq_pipeline.c, although
>> that's surely neatnik-ism not anything meaningful.
> Yeah, the code looks much better this way. I thought it was a bit odd
> that a function called confirm_result_status() would actually consume
> said status. Would it be better as
> consume_result_status(PGconn *conn, ExecStatusType expected)
> ?
Hm, I chose that name by analogy to the adjacent
confirm_query_canceled(), which is likewise consuming a result.
I agree that "consume" is a better verb, but then let's rename
confirm_query_canceled as well.
> I think the patch is a clear improvement regardless.
Thanks for reviewing!
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-bugs@postgresql.org
Cc: tgl@sss.pgh.pa.us, alvherre@kurilemu.de, d.kovalenko@postgrespro.ru, pgsql-bugs@lists.postgresql.org
Subject: Re: BUG #18960: Mistake in test test_simple_pipeline (libpq_pipeline.c)
In-Reply-To: <803146.1756910897@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox