pg.ddx.io  pgsql-hackers@postgresql.org mailing list archive  
help / color / mirror / Atom feed
From: Tom Lane <tgl@sss.pgh.pa.us>
To: Nathan Bossart <nathandbossart@gmail.com>
Cc: Thibaud W. <thibaud.walkowiak@dalibo.com>
Cc: pgsql-hackers@lists.postgresql.org
Subject: Re: Proposal: adding a better description in psql command about large objects
Date: Fri, 03 Jun 2022 11:12:11 -0400
Message-ID: <216601.1654269131@sss.pgh.pa.us> (raw)
In-Reply-To: <20220603143921.GA2624579@nathanxps13>
References: <43f0439c-df3e-a045-ac99-af33523cc2d4@dalibo.com>
	<20220602214625.GA2494933@nathanxps13>
	<2e872233-1642-439c-dd94-56fc25d398cb@dalibo.com>
	<20220603143921.GA2624579@nathanxps13>

Nathan Bossart <nathandbossart@gmail.com> writes:
> Yes, it looks like the precedent is to have an fprintf() per command.  I
> still think the indentation needs some adjustment for readability.  In the
> attached, I've lined up all the large object commands.  This is offset from
> most other commands, but IMO this is far easier to read, and something
> similar was done for the operator class/family commands.  Thoughts?

Generally +1 here.  The other style that is used in some places is to
put the description on a separate line, but given that we're setting
the indent for a whole command group I think this looks better.

A couple of other random thoughts:

* How about "write large object to file" and "read large object from
file"?  As it stands, if you are not totally sure which direction is
export and which is import, this description teaches you little.

* While we're here, it seems like this whole group was placed at the
end because of add-it-to-the-end-itis, not because that was the
most logical place for it.  The other commands that interact with
the server are mostly further up.  My first thought is to move it
to just after the "Informational" group, but I'm not especially
set on that.  Making it not-last might make it harder to get away
with the inconsistent indentation, though.

			regards, tom lane





view thread (10+ messages)  latest in thread

Message-ID: <216601.1654269131@sss.pgh.pa.us>
Permalink:  ../216601.1654269131@sss.pgh.pa.us/
Also on:    postgresql.org/message-id/216601.1654269131@sss.pgh.pa.us

 · 

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: pgsql-hackers@postgresql.org
  Cc: tgl@sss.pgh.pa.us, nathandbossart@gmail.com, thibaud.walkowiak@dalibo.com, pgsql-hackers@lists.postgresql.org
  Subject: Re: Proposal: adding a better description in psql command about large objects
  In-Reply-To: <216601.1654269131@sss.pgh.pa.us>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox