From: Tom Lane <tgl@sss.pgh.pa.us>
To: Robert Haas <robertmhaas@gmail.com>
Cc: Michael Paquier <michael@paquier.xyz>
Cc: Anton A. Melnikov <a.melnikov@postgrespro.ru>
Cc: Daniel Gustafsson <daniel@yesql.se>
Cc: Peter Eisentraut <peter@eisentraut.org>
Cc: PostgreSQL Hackers <pgsql-hackers@postgresql.org>
Subject: Re: Use XLOG_CONTROL_FILE macro everywhere?
Date: Fri, 26 Apr 2024 16:51:17 -0400
Message-ID: <30207.1714164677@sss.pgh.pa.us> (raw)
In-Reply-To: <CA+TgmoaivCgqRCD+XKAVid=+W+zz1-GNN1SQFz2Bubtfn7vEMw@mail.gmail.com>
References: <0841ec77-47e5-452a-adb4-c6fa55d605fc@postgrespro.ru>
<474746ef-fa9f-400e-902e-3bb018320ca0@eisentraut.org>
<44faf5a1-1e84-4ae5-9ea7-106af77cf96b@postgrespro.ru>
<FC257A2E-D989-46DC-8232-AB14C3D7A0B2@yesql.se>
<6457915f-f880-452d-a4ae-21a5bfbccbd3@postgrespro.ru>
<ZimeCrx0IoiIQpJU@paquier.xyz>
<CA+TgmoaivCgqRCD+XKAVid=+W+zz1-GNN1SQFz2Bubtfn7vEMw@mail.gmail.com>
Robert Haas <robertmhaas@gmail.com> writes:
> On Wed, Apr 24, 2024 at 8:04 PM Michael Paquier <michael@paquier.xyz> wrote:
>> Not sure that I would bother with a second one. But, well, why not if
>> people want to rename it, as long as you keep compatibility.
> I vote for just standardizing on XLOG_CONTROL_FILE. That name seems
> sufficiently intuitive to me, and I'd rather have one identifier for
> this than two. It's simpler that way.
+1. Back when we did the great xlog-to-wal renaming, we explicitly
agreed that we wouldn't change internal symbols referring to xlog.
It might or might not be appropriate to revisit that decision,
but I sure don't want to do it piecemeal, one symbol at a time.
Also, if we did rename this one, the logical choice would be
WAL_CONTROL_FILE not PG_CONTROL_FILE.
regards, tom lane
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-hackers@postgresql.org
Cc: tgl@sss.pgh.pa.us, robertmhaas@gmail.com, michael@paquier.xyz, a.melnikov@postgrespro.ru, daniel@yesql.se, peter@eisentraut.org
Subject: Re: Use XLOG_CONTROL_FILE macro everywhere?
In-Reply-To: <30207.1714164677@sss.pgh.pa.us>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by DDX for PostgreSQL; see mirroring instructions
for how to clone and mirror all data and code used for this inbox