agora inbox for pgsql-sql@postgresql.org
help / color / mirror / Atom feedFrom: Adrian Klaver <adrian.klaver@aklaver.com>
To: Stuart <sfbarbee@gmail.com>
To: Tom Lane <tgl@sss.pgh.pa.us>
Cc: pgsql-sql@postgresql.org <pgsql-sql@postgresql.org>
Subject: Re: ERROR: cache lookup failed for type
Date: Sun, 16 Aug 2015 21:08:39 -0700
Message-ID: <55D15E47.9020007@aklaver.com> (raw)
In-Reply-To: <55D15A62.70406@gmail.com>
References: <55D131B0.6010500@gmail.com>
<15241.1439781395@sss.pgh.pa.us>
<55D15A62.70406@gmail.com>
List-Unsubscribe: <mailto:majordomo@postgresql.org?body=unsub%20pgsql-sql>
On 08/16/2015 08:52 PM, Stuart wrote:
> Adrian, Tom,
>
> I reloaded the database and the problem doesn't happen anymore.
> Thanks for the suggestion.
>
> Tom - to answer your questions,
>
> On 08/17/2015 07:16 AM, Tom Lane wrote:
>>> I dropped the function and can now not add it back to the database.
>>
>> What happens when you try, exactly?
>
> The same error occurred
>
>> I assume the error was persistent across multiple sessions? Have you
>> changed the schema (rowtype) of table documents_statistics lately?
>
> No there were no changes to the table schema. All dbase objects were
> loaded via
>
> pg_dumpall > file.sql
>
> upgrade postgres
>
> psql template1 -f file.sql
So this is what you did when you started with the Alpha 1 database, correct?
When you went to Alpha 2 you just installed the new program over the
existing Alpha 1, but left the data directory as is and then ran into
the error, correct?
You then did a dump of the Alpha 1 or other(?) existing database and
then a restore into the Alpha 2(the reload above) at which point the
error went away, correct?
>
> Yes the problem was persistent across multiple sessions
>
>> Does reindexing pg_type make the error go away? If so, what platform
>> and filesystem is this on?
>
> No, I didn't try reindexing pg_type
>
> The filesystem is XFS
>
>
> Thanks,
>
> Stuart
>
--
Adrian Klaver
adrian.klaver@aklaver.com
--
Sent via pgsql-sql mailing list (pgsql-sql@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-sql
view thread (9+ messages) latest in thread
Message-ID: <55D15E47.9020007@aklaver.com>
Permalink: ../55D15E47.9020007@aklaver.com/
Also on: postgresql.org/message-id/55D15E47.9020007@aklaver.com
reply
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Reply to all the recipients using the --to and --cc options:
reply via email
To: pgsql-sql@postgresql.org
Cc: adrian.klaver@aklaver.com, sfbarbee@gmail.com, tgl@sss.pgh.pa.us
Subject: Re: ERROR: cache lookup failed for type
In-Reply-To: <55D15E47.9020007@aklaver.com>
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox